Jump to content

Michael Lambert

Member
  • Content Count

    3
  • Joined

  • Last visited

Community Reputation

0 Neutral

About Michael Lambert

  • Rank
    New Member

Profile Information

  • Name
    Array
  • Location
    Array
  • Drives
    Array

Recent Profile Visitors

The recent visitors block is disabled and is not being shown to other users.

  1. I have a 03 Silverado 2500HD 6.0L. My original issue started when I went through a rough patch of road. My truck stalled at 3,000 rpm and would not start right up After about 10 min the truck would start but would not go over 3,000 before the light would start flashing and the engine would start stalling. Happened 2 more times before the tow truck came. Got the truck home and it started up on the tow truck and backed it out. Did the stall issue again with hopes of recording the code when it completely died and would not start up again. I lost all accessory control and had ABS, power red message, and airbag message. The security light would stay on and I would not have the CE light appear at all. Eventually with tinkering I was able to get the CE light to appear and the truck would attempt to start but sounds like I have 2 bad batteries (both are continually on chargers and metering around 12.5-12.8 V). Eventually it would go back into the screwy mode and I'll lose window, lock, etc. I've replaced the starter and ignition switch, cleaned and reattached the motor and frame grounds, pulled the fuse box cleaned/inspected wires, all fuses are good and relay swapped and working. After the ignition switch was replaced I was able to reprogram the security and got the light back and pulled a P1518 code. The truck tried to start again but did not sound like it was getting enough volts and I got all window,lock,etc controls back. I'm now back to no CE light (no OBD communication) and the security light back on. Is the BCM not communication with the vehicle?
  2. I have a 03 Silverado 2500HD 6.0L. My original issue started when I went through a rough patch of road. My truck stalled at 3,000 rpm and would not start right up After about 10 min the truck would start but would not go over 3,000 before the light would start flashing and the engine would start stalling. Happened 2 more times before the tow truck came. Got the truck home and it started up on the tow truck and backed it out. Did the stall issue again with hopes of recording the code when it completely died and would not start up again. I lost all accessory control and had ABS, power red message, and airbag message. The security light would stay on and I would not have the CE light appear at all. Eventually with tinkering I was able to get the CE light to appear and the truck would attempt to start but sounds like I have 2 bad batteries (both are continually on chargers and metering around 12.5-12.8 V). Eventually it would go back into the screwy mode and I'll lose window, lock, etc. I've replaced the starter and ignition switch, cleaned and reattached the motor and frame grounds, pulled the fuse box cleaned/inspected wires, all fuses are good and relay swapped and working. After the ignition switch was replaced I was able to reprogram the security and got the light back and pulled a P1518 code. The truck tried to start again but did not sound like it was getting enough volts and I got all window,lock,etc controls back. I'm now back to no CE light and the security light back on. Should I be ordering an ignition or sending it to the chevy dealer for a BCM/PCM replace and reprogram? Sorry for the long post and any help is greatly appreciated.
×
×
  • Create New...

Important Information

By using this site, you agree to our Terms of Use.