Jump to content

nate1dawgg

Member
  • Content Count

    112
  • Joined

  • Last visited

Community Reputation

2 Neutral

About nate1dawgg

  • Rank
    Enthusiast

Contact Methods

  • Website URL
    http://

Profile Information

  • Name
    Nathan
  • Location
    AZ
  • Gender
    Male
  • Drives
    2011 Silverado LTZ CC

Recent Profile Visitors

6,954 profile views
  1. Hey Ryan were you ever able to find those pictures?
  2. Would I be able to put a 2014+ heated steering wheel in my 2011? Sent from my Pixel XL using Tapatalk
  3. Hey Ryan, the original post pics are loading for me. Think you'd be able to update them or is it just me?
  4. I'm looking to upgrade my gears and wanted everyone's opinion on brands. The shops I've found so far offer Yukon, G2 or Sierra. Any thoughts on these brands? Any other brands anyone recommends?
  5. I was just wanting to compare what the computer is saying to what my gauge is reading.
  6. Is there a way to check the fuel level of the truck from the autocal?
  7. Bought these for my 2011 Silverado, but ended up deciding to go a different way. These haven't even left the box. Selling for $105 shipped in the US. http://www.xenondepot.com/H11-LED-headlight-kit-p/h11-led-hl.htm
  8. So just a follow up to this, apparently there is something out there that addresses this. #PIP4792D. Had the shop look at the alcohol content and sure enough it was off. Got it calibrated to the right specs and so far haven't had any other problems.
  9. So it cranks longer than normal, and only when it's been sitting in the cold for a longer period of time. When I start it in the morning (a longer crank) and then turn it off and turn it back on, the second time i turn it on, it starts up immediately, no long cranking. And this started happening last year, prior to that, it always started right away. I'm not sure what the shop has checked, like I said, they thought they fixed it before, but no so much. I'll ask them when I'm in today.
  10. So I've got a bunch of people stumped with this one. Hopefully someone here has some suggestions. My '11 1500 LTZ has interesting issues starting when it's cold out and has been sitting for a while (6+ hours). When I go to start it, I'll turn the key, and it will crank for a few seconds and then finally catch and start. While it's cranking, I'm not holding the key in the start position, I actually don't even touch the key. So first thought, battery. Less than a year old battery, but I figured I'd check. Good battery, no problems there. So I took it to the shop, they looked at it
  11. Well I'm open to options for the front and rear. I was going with Bilstiens since I've heard on overwhelming response across multiple boards for them. However as I said in a previous post, I'm open to what I put in, I just want something good. I'd also like options with removing the level and with keeping it. I definitely don't have a lot of knowledge on shocks/struts in general, so I like everyone's opinion.
  12. Thanks for the info BlackZ71, I'm definitely not locked in to a specific brand, just looking for a good set. Are you running the QuickLift struts along with your 2" level? Are the struts lifting it more than the level or is it at a setting that doesn't lift it? Same question for the shocks, is there additional lift to the 3" block or did the heights not change?
×
×
  • Create New...

Important Information

By using this site, you agree to our Terms of Use.