Jump to content

Bigmoore

Member
  • Content Count

    96
  • Joined

  • Last visited

Community Reputation

21 Good

About Bigmoore

  • Rank
    Enthusiast
  • Birthday 06/30/1993

Profile Information

  • Name
    Array
  • Location
    Array
  • Gender
    Array
  • Interests
    Array
  • Drives
    Array

Recent Profile Visitors

2,938 profile views
  1. How do you like the ridge grapplers? I was looking at them for mine. Sent from my iPhone using Tapatalk Pro
  2. No loud ticking like before on cold start! I’ll keep an eye on it for the next few days. Sent from my iPhone using Tapatalk Pro
  3. I would too, but I am afraid to considering I have an issue at 20k miles with a lot of warranty left. Sent from my iPhone using Tapatalk Pro
  4. So it’s definitely more quiet. It was already a little warm when I got it back. I will take a video in the morning when it’s fully cold and post it. Sent from my iPhone using Tapatalk Pro
  5. I’ll keep you posted. Hoping that’s it Sent from my iPhone using Tapatalk Pro
  6. So I just heard from the dealer. They said it was the vacuum pump. They replaced it and said the tick went away. Going to pick it up after work. Hopefully that was the fix. Sent from my iPhone using Tapatalk Pro
  7. That’s my thoughts as well. I have a 2019 Mustang GT with the 5.0L and it actually has the exact tick that my truck has. Goes away when it is cool. Ford deemed it as normal, so I am curious to see if GM can find anything wrong. Sent from my iPhone using Tapatalk Pro
  8. Got an appointment with the dealer and sent them the video of the tick. Hopefully they can hear it. Sent from my iPhone using Tapatalk Pro
  9. Is this something that has been happening on a lot of the 5.3s? I had a 2014 with 40k on it and it didn’t have this issue. Are there any service bulletins out there for the issue yet? How concerned should I be with driving it until it gets fixed? Sent from my iPhone using Tapatalk Pro
  10. I just turned over 20k miles. It sure does. Made in Mexico. Is there a manufacturing issue with the ones built down there? Sent from my iPhone using Tapatalk Pro
  11. Hi all. I have a 2018 Sierra 1500 with the 5.3. The other day, I heard this abnormal, non-rhythmic tick during cold start. I haven’t heard it when it is warm. Link to video: Anyone have any idea what could be causing this? Or is this normal? Sent from my iPhone using Tapatalk Pro
  12. Hi guys, I’m looking for the part number for the front passenger side parking sensor for the front bumper. Mine was knocked out by a rock on the highway (perfectly hit it dead center too). The sensor is cracked. Anyone know of the part number? If there is a thread for this, please point me there. Didn’t have any luck finding one. Sent from my iPhone using Tapatalk Pro
  13. May be unrelated but I am having a similar issue with my backup camera. There’s a service bulletin for the rear camera system, PIT5552B, which says that if you have any 12 volt accessory plugged in, like a dash cam or gps, it is causing feedback into the harness, my guess is that it’s not shielded properly. I just went through this yesterday at the dealer and they basically said they can’t do anything to fix it and I have to unplug my dashcamera is I want to use my backup camera as it is intended. Sent from my iPhone using Tapatalk Pro
  14. Hi all, I hope I’m not the only one frustrated with this issue. For a few months, I have had issues with my back up camera being very fuzzy/grainy, which is almost unusable at night. I took it in to my local dealership and found out that there is a technical bulletin for this issue basically saying that if any 12 volt accessory plugged in, it is causing the issue. In my case, it’s a dash cam that is on all the time. Basically I was told that there is nothing they can do and I need to unplug my dash camera to have a useable backup camera. For a 2018 Sierra, I would expect there wouldn’t be these issues as I didn’t have them in my 2014. Has anyone figured out a workaround to still allow the 12 volt accessory to be plugged in but not cause the grainy/fuzzy output? PIT5552B is the bulletin. Sent from my iPhone using Tapatalk Pro
  15. I got one on the top of my rear door on my way home with the dealership with it. Just surprising how weak it is. Disappointed for how much I paid for my truck... Sent from my iPhone using Tapatalk Pro
×
×
  • Create New...

Important Information

By using this site, you agree to our Terms of Use.