Jump to content

Bigmoore

Member
  • Content Count

    99
  • Joined

  • Last visited

Community Reputation

21 Good

About Bigmoore

  • Rank
    Enthusiast
  • Birthday 06/30/1993

Profile Information

  • Name
    Array
  • Location
    Array
  • Gender
    Array
  • Interests
    Array
  • Drives
    Array

Recent Profile Visitors

2,987 profile views
  1. Long story short, my dad got into an accident in his 17 and needs taillights. With the GM strike, he’s having trouble getting factory ones. I was going to see if there were any aftermarket ones and give him mine so he can get back on the road. He’s just waiting on taillights Sent from my iPhone using Tapatalk Pro
  2. I’m looking for aftermarket taillights for my 18 Sierra 1500 SLT but I have not had much luck finding a set that will work with my truck since it came with factory LED taillights. Anyone have any recommendations? Sent from my iPhone using Tapatalk Pro
  3. Hey Guys, I am looking to level my truck with 5100s all around, setting the front at the highest setting. Does anyone have pictures of the angles of everything after installing them? I had some issues on my old 2014 with just a 2.5" spacer kit and i want to make sure i avoid it going with these. Thanks in advance.
  4. How do you like the ridge grapplers? I was looking at them for mine. Sent from my iPhone using Tapatalk Pro
  5. No loud ticking like before on cold start! I’ll keep an eye on it for the next few days. Sent from my iPhone using Tapatalk Pro
  6. I would too, but I am afraid to considering I have an issue at 20k miles with a lot of warranty left. Sent from my iPhone using Tapatalk Pro
  7. So it’s definitely more quiet. It was already a little warm when I got it back. I will take a video in the morning when it’s fully cold and post it. Sent from my iPhone using Tapatalk Pro
  8. I’ll keep you posted. Hoping that’s it Sent from my iPhone using Tapatalk Pro
  9. So I just heard from the dealer. They said it was the vacuum pump. They replaced it and said the tick went away. Going to pick it up after work. Hopefully that was the fix. Sent from my iPhone using Tapatalk Pro
  10. That’s my thoughts as well. I have a 2019 Mustang GT with the 5.0L and it actually has the exact tick that my truck has. Goes away when it is cool. Ford deemed it as normal, so I am curious to see if GM can find anything wrong. Sent from my iPhone using Tapatalk Pro
  11. Got an appointment with the dealer and sent them the video of the tick. Hopefully they can hear it. Sent from my iPhone using Tapatalk Pro
  12. Is this something that has been happening on a lot of the 5.3s? I had a 2014 with 40k on it and it didn’t have this issue. Are there any service bulletins out there for the issue yet? How concerned should I be with driving it until it gets fixed? Sent from my iPhone using Tapatalk Pro
  13. I just turned over 20k miles. It sure does. Made in Mexico. Is there a manufacturing issue with the ones built down there? Sent from my iPhone using Tapatalk Pro
  14. Hi all. I have a 2018 Sierra 1500 with the 5.3. The other day, I heard this abnormal, non-rhythmic tick during cold start. I haven’t heard it when it is warm. Link to video: Anyone have any idea what could be causing this? Or is this normal? Sent from my iPhone using Tapatalk Pro
  15. Hi guys, I’m looking for the part number for the front passenger side parking sensor for the front bumper. Mine was knocked out by a rock on the highway (perfectly hit it dead center too). The sensor is cracked. Anyone know of the part number? If there is a thread for this, please point me there. Didn’t have any luck finding one. Sent from my iPhone using Tapatalk Pro
×
×
  • Create New...

Important Information

By using this site, you agree to our Terms of Use.