Jump to content

Jtv213

Member
  • Content Count

    7
  • Joined

  • Last visited

Community Reputation

0 Neutral

About Jtv213

  • Rank
    Enthusiast

Profile Information

  • Name
    Array
  • Location
    Array
  • Drives
    Array
  1. I been trying to find front lower control arm bushings for my 2006 Silverado 1500 ext 2wd with the coil spring front suspension . But it’s never a clear answer I bought everything else already and these are the last things left up front anyone done these and maybe have a part number you can shoot me so I can order them
  2. I been trying to find front lower control arm bushings for my 2006 Silverado 1500 ext 2wd with the coil spring front suspension . But it’s never a clear answer I bought everything else already and these are the last things left up front anyone done these and maybe have a part number you can shoot me so I can order them
  3. Thanks guys and Yes so it did relearn itself no engine light or anything really almost 200000 miles and she is running like a champ hopefully sometime this year I’ll be doing a cam and springs so I’ll probably be adding another post with some more questions thanks again guys
  4. So yea I opened up the throttle manually didn’t know another way was possible and I torqued everything back to spec and I did have a code on for a while for the knock sensor and the rear knock sensor was completely corroded and also bank 1and 2 lean so I assumed the intake gasket as everyone referred it too and I’ll check again all the hoses and I also heard of a PCv valve problem could that be a issue? And before I tore it apart it started to act up like seriously as I started to pull in the drive way to take it apart it start idleing all crazy almost like starving for fuel and that was the only time that has happened . And so I forgot to mention I took it too autozone to use there fuel pressure tool and on the key on position it jumped to 50psi and while running it was sitting at 60 so I don’t know if that’s a problem or maybe a fuel filter
  5. So I just replaced my knock sensors and wiring and also new felpro Intake gaskets, now it starts up. It when it starts it stays high in idle then slowly comes down kinds like I’m on the gas and slightly letting off little by little . But I also cleaned out the throttle body since it was a little built up with carbon, but when I did these things then back knock sensor was complete corroded and the front was ok so I did the dam thing with the red rvt for the water and also the felpro gaskets we’re different then my original ones they Didn’t clip on to the intake like the old ones they laid in the head bolts with little eye lits ,don’t know if that is a problem. But so I started the truck and it did as I mentioned and when I gave it gas it kind of sputtered until it hit about 1600rpm then reved up noramally but if I let it drop to a idle again and stab it it does it again then I drove it around and it seems the idle is staying up even when I’m off the gas and is still pushing the truck forward until I stop all the way then it will come down to a idle of 7-800 again. Help me out I’m lost with this one
×
×
  • Create New...

Important Information

By using this site, you agree to our Terms of Use.