Jump to content

Northeast4050

Member
  • Content Count

    28
  • Joined

  • Last visited

Everything posted by Northeast4050

  1. All recalls done thus far...maybe something else will come out that will be the magical fix. Thanks for the suggestion, I appreciate it.
  2. Good advice...I'm on #2 now and am good friends with a service manager at another and have been running it all through him too...he's thinking they need to send an engineer from GM to look into it. Giving the current dealer a chance to see what they come up with...I'm done with the "We reset everything it should be good now" answers.
  3. Sorry in advance for the long winded post here, I am looking for help...and lots of it. I've got a 2019 AT4 with the 6.2l and it has been nothing but problems since I purchased it. It started early on in its life with the speedo having a mind of its own bouncing up and down when on cruise control but the truck wasn't actually changing speeds. The check engine light came on and it was brought to the dealer - cleared codes and couldn't replicate it and sent me on my way. Months later more issues - this time my low fuel light came on (had a full tank) followed by the service electronic stability control warning, a warning telling me steering assist was reduced and to drive with care along with the traction control off light and the check engine light. Brought it in to be checked and dealer said there were no codes and they could not duplicate the issue and sent me on my way. For whatever reason they wouldn't tell me why the check engine light was on. Less than two weeks later the transmission stopped shifting properly - 60mph and felt like the e brake was on, revving very high...check engine light came back on and had it towed back to the dealer. This time they found codes....A LOT OF CODES...they said a number of the modules were not talking to the ECM. They reset all of them, test drove it and said it was fine. The next morning they fired it up and it duplicated...the check engine light was back on with a number of different modules not communicating with the ECM. They were completely unsure what to do and called GM's tech line and they provided them an update for the ECM saying they didn't think it would fix it but it was worth a shot. They kept the truck a few more days, couldn't duplicate it again and returned it to me. Two weeks later (November 28) driving up the highway and the fuel light error comes back on along with all the steering and traction warnings. This time I also got trailer connection errors (but I wasn't towing a trailer). The check engine light came on but when I got to my destination all the lights turned off and it seemed ok again. Fast forward to today and as you may have guessed, driving up the highway and more issues. This time it was everything at once...every light I've seen and haven't seen on the dash, traction and steering warnings, reduced power, throttle wouldn't work...I limped it to the side of the highway and it died. Wouldn't start but everything electrically seemed to have power. Had it towed back to the dealer...and there it sits. I've attached a photo of today...it shows some of the lights that were on but not all...it kept resetting itself and new lights came on and off, it was very strange. Has anyone seen ANY of these similar issues and had any success working through them? I know its a lot...it really sucks. The first new truck in my life...my dream truck and it's been nothing but a problem. 16,000 miles, only 93 octane fuel as recommended...and I baby this thing. Thanks in advance...
  4. Anyone with a plow put this on their truck yet? https://timbren.com/blog/products-page/gmfk15cc/ After talking to Timbren it sounds like it was designed for the standard suspension trucks not the AT4 or trail boss so I'm curious about measurements on it and if it will fit. As I understand it they are on back-order until tomorrow or Monday then will begin shipping again. They said once I get it installed to measure the distance from the bottom of the rubber spring to the top of the upper control arm if it is not sitting on it and they will be able to send me a spring up to 1.5" bigger. They said depending on how GM installed the 2" lift for the AT4 it still may fit like it is supposed to. Anyone willing to go out to their truck and measure the distance from the hole here on the frame to the top of the upper control arm for me? I've marked it out in the photo below. (Not At4 or trail boss) Thanks in advance!
  5. I was driving my 2019 Sierra AT4 on the highway with my cruise on 70 and the cruise suddenly shut off. I turned it back on and it seemed normal...a short time later my check engine light came on with no obvious side effects. I parked the truck for 2 days before driving again...check engine light shut itself off. I got back on the highway and set the cruise to 75...this is when it got weird...the truck told me the cruise was set to 77...then it changed to 72...and back to 77. It continued to do this with the speedometer jumping up and down but no obvious speed or RPM change. Anyone else experience anything like this? I took a video of it to show the dealer but not sure they are gonna know what it was doing...
  6. Just checked the glove box for my 2019 Sierra AT4 and couldn't find the RPO label. Anyone else missing theirs or has GM hidden it somewhere else? It's not on the drivers side B pillar and there was a recall on my truck for a missing sticker related to the performance air intake...maybe they forgot the RPO?
  7. Hey, I wish i did but I've got nothing. I submitted an idea to Leer through their website but haven't heard anything...
  8. Good to know it's not just me. I added the boost kit allowing my high beams on with my fogs and thought it screwed with them when auto was on...
  9. Here is it! Let me know if it works or not... 2019_06_02_16_47_02.pdf
  10. I ordered the hypertech Speedometer Calibrators Inline - Part #730129 after installed my 35's...speedo was off by quite a bit at higher speeds and with a new truck i wanted it spot on. The calibrator was very easy to program and install and after checking with two difference GPS devices and a radar it is now spot on. Highly recommended.
  11. Sorry been super busy. Trying to get it done for you asap.
  12. Are you still looking for the instructions? I can provide if so...installed this past weekend, pretty straight forward
  13. So twice now, both after initial startup I have put my truck in reverse, backed up, stopped and put it in drive, then attempted to go forward (all in a fluid motion with a very short stop) but found the truck had shut down. I am assuming this has to do with the auto start feature but it certainly shouldn't be doing this. I talked to my trusted dealer and he said it definitely shouldn't be shutting down in reverse and furthermore the auto start feature shouldn't be activating until the truck has warmed up. He said if they could get it to replicate a TSB would likely go out on it and possibly a safety recall. Has anyone else experienced this symptom?
  14. Keep us posted, this is super interesting and promising...I'd love to add it to my At4 with technology package
  15. I can't say based on experience but I would be shocked if you couldn't just swap them...but I'm just basing that off previous generations of gm trucks not anything I've seen done as of yet
  16. Looks sharp. How long did it take you to bust that out?
  17. Selling center console locker for 2014-2018 sierra or silverado 1500 and 2015-2018 2500 and 3500's. Lock'er down model is LD2040...google it for pictures. Looking to get $225 and I'll pay shipping. Send me a PM if you're interested.
  18. I've got a 6.2 and also have the performance package with cat back exhaust...I've been noticing the same vibration...its minor but its noticeable and annoying...super frustrating for a 66k truck with 400 miles on it.
  19. Yea I recognize the weight and really wanted the 285 70 18's for their 34" size and 59lbs but they were crazy expensive and the 285 75's were misordered by someone so the price was too good to pass up. Not to mention I had a set of tire chains from my Duramax that conveniently fit the 285 75's...it all worked out for me!
  20. Did you get it alligned after the motofab lift? If not have you noticed your tires wearing unevenly?
  21. Anyone have any thoughts or solutions on how to keep the factory rear HD camera (integrated into the third brake light and plays through the rear view mirror)working after adding a truck cap? Is there a wiring harness that can be added with an accessory camera? I ordered a cap then realized this will be a problem. Not a deal breaker, I need to keep my things dry but the camera is a pretty cool feature. Thanks in advance!
  22. 285 75 18...35" nitto ridge grapplers fit the stock setup. Zero trimming zero rubbing
×
×
  • Create New...

Important Information

By using this site, you agree to our Terms of Use.