Jump to content

whaler

Member
  • Content count

    179
  • Joined

  • Last visited

Community Reputation

26 Good

About whaler

  • Rank
    Enthusiast

Contact Methods

  • Website URL
    http://

Profile Information

  • Location
    Newbrunswick Canada

Recent Profile Visitors

4,676 profile views
  1. Gents Noticing that one of my running boards are getting very lazy. Has anyone had any issues with them? Thanks Sent from my iPhone using Tapatalk
  2. Diablo i3 = Junk

    Guys I have a 16 Denali 6.2 that is a daily driver. Thinking about a tune. Friend of mine has the I3 tune and has offered it to me. After reading through these posts I am wondering what would be best? My truck is stock. No interest in CAI or cams and etc. Just looking for a little wake up. Any suggestions please? Thank you Sent from my iPhone using Tapatalk
  3. Diablo i3 = Junk

    Interesting Sent from my iPhone using Tapatalk
  4. This is exactly why you never buy on the first year of a new model. Sent from my iPhone using Tapatalk
  5. Thank you. I will try that Sent from my iPhone using Tapatalk
  6. I have a 2016 Denali Ultimate. Great truck with no issues...until now. The running boards deploy when you open the door. Something weird has started. My passenger side deploys for no reason. I was working in the garage, no keys in truck, doors are all closed and not working on truck.....out comes the passenger step. I live in Canada and thought the cold temps may be an issue? I have a heated garage, doesn’t matter. Anyone else having issues with these things? Thoughts? Sent from my iPhone using Tapatalk
  7. I find this very frustrating too. My fish finder has a better picture...even HD! Come on GM! Sent from my iPhone using Tapatalk
  8. Cargo Lights on with Reverse Lights

    Did this on my last two trucks. Worked perfectly. Not sure why you guys are having issues? You can’t be doing it right. Go through this thread carefully. It’s all there. Sent from my iPhone using Tapatalk
  9. Well in fact it is true. I had a 2014 with lots of issues. A few GM could solve. My brother had one from the 80s and a first run. Also many issues. You, just got lucky. Sent from my iPhone using Tapatalk
  10. Prime reason not to buy in the launch year. Always lots of issues. Sent from my iPhone using Tapatalk
  11. Check the tail gate cables. Almost all are not the same. Sent from my iPhone using Tapatalk
  12. I had a look at the 19 Denali. Not impressed at all. I will wait a few years for sure. Never buy on the first year of release. My 16 works great Sent from my iPhone using Tapatalk
  13. These aren’t huge issues but when you add them all up and then you have the cost to it....it does become a bit of a disappointment. Sent from my iPhone using Tapatalk
  14. Actually the new trucks disappoint me over my 2016. So does the tilt steering, turn signal in the mirror, power pedals and more. May just keep what I have for a few more years. Sent from my iPhone using Tapatalk
  15. I don’t like that at all. I guess I will Wait a few years Sent from my iPhone using Tapatalk
×

Important Information

By using this site, you agree to our Terms of Use.