Jump to content

Clay_Lucas

Member
  • Content count

    84
  • Joined

  • Last visited

Community Reputation

4 Neutral

About Clay_Lucas

  • Rank
    Enthusiast

Recent Profile Visitors

2,472 profile views
  1. Ok, I've decided to spend a little more on the headers. I'll have $1000 to spend, maybe a bit more. What would be the best headers I can get in this price range? I'm looking at these here: https://www.kooksheaders.com/1999-2013-gm-1500-series-1-7-8-x-3-truck-header.html Going to have it tuned and the egr removed, so that should give me a few more options. Sent from my SM-N900T using Tapatalk
  2. Did you move any wires befor the power came back on? Doesn't sound like a battery issue. Sent from my SM-N900T using Tapatalk
  3. I've seen a lot of positive reviews for these. Can you recommend a set or manufacturer? Sent from my SM-N900T using Tapatalk
  4. Awesome, looks like these should work. Probably not doing the work myself, taking it to a local shop. I only needs the headers, not the other piping. Sent from my SM-N900T using Tapatalk
  5. I have a half ton. Did the 6.0 swap not too long ago, getting the exhaust work done now. The only issue I think I might have with that's would be the 4x4 parts, but I'm not really sure. They look decent for the price, should breathe a little better than short tubes? Sent from my SM-N900T using Tapatalk
  6. http://vi.raptor.ebaydesc.com/ws/eBayISAPI.dll?ViewItemDescV4&item=181265341232&category=33632&pm=1&ds=0&t=1500584789460&cspheader=1 Would these work on a 4x4 6.0 Silverado? Sent from my SM-N900T using Tapatalk
  7. Trying to find a set of long tubes for my 2000 6.0 4x4 Silverado. I don't have a lot of $ to spend, I'm looking for something in the $300-$500 range. With egr port. Anyone know of some inexpensive options?? Sent from my SM-N900T using Tapatalk
  8. 6.0 swap exhaust questions.

    Misfire codes haven't come back yet. I am having a issue with the new transmission. It has a 2000rpm stall. If I get close to 2k rpm it shudders pretty bad. If I drop down a gear or bring the rpm up it goes away and feels/shifts fine. Is this normal? Hopefully I won't have to replace it. I don't think the tunner did anything for the transmission computer. Sent from my SM-N900T using Tapatalk
  9. 6.0 swap exhaust questions.

    Crank relearn seemed to fix it for the most part. I still get the code but it only comes up as a pending falt. I did turn the light on once but hasn't come back (as a current fault) sense. Sent from my SM-N900T using Tapatalk
  10. 6.0 swap exhaust questions.

    Is it very harmful to run the engine befor getting this fixed? I won't ha e much spare time for a few days. Sent from my SM-N900T using Tapatalk
  11. 6.0 swap exhaust questions.

    All I have is my Bluetooth scanner. The alternator was definitely bad. Didn't fix the misfire, but now the check engine light doesn't come on as fast or as frequently as it did with the bad alternator. Sent from my SM-N900T using Tapatalk
  12. 6.0 swap exhaust questions.

    The engine was out of a 04-05. Sent from my SM-N900T using Tapatalk
  13. 6.0 swap exhaust questions.

    I had it custom tuned. But still have the 5.3 computer Sent from my SM-N900T using Tapatalk
  14. 6.0 swap exhaust questions.

    Alternator quit working at higher rpm. I think that's the issue, only misses around 3000 rpm. Sent from my SM-N900T using Tapatalk
  15. 6.0 swap exhaust questions.

    Swap is done. Only issue I have is a very small header leak and a p0300 random misfire code. I've checked for vacuum leaks around the intake and every vacuum hose I can see and didn't find anything. Vacuum is pretty steady at idle, mas airflow sensor is working. Both upstream 02's are new. Plugs and wires were replaced last year. From what I've read so far, I think I need to do the crank variation relearn? Is there anyway I can do this myself or do I need to take it to the dealership? Sent from my SM-N900T using Tapatalk
×

Important Information

By using this site, you agree to our Terms of Use.