Jump to content

stassin22

Member
  • Content Count

    95
  • Joined

  • Last visited

  • Days Won

    1

stassin22 last won the day on December 16 2018

stassin22 had the most liked content!

Community Reputation

65 Good

About stassin22

  • Rank
    Enthusiast

Profile Information

  • Name
    Array
  • Location
    Array
  • Drives
    Array

Recent Profile Visitors

1,754 profile views
  1. I believe the terminals for the cluster are 928999 there should be a link to some on amazon in an earlier post that’s where I got mine from Sent from my iPhone using Tapatalk
  2. After some long patient wiring and soldering and thanks to WAMS for programming I now have a Denali cluster in my rcsb Sent from my iPhone using Tapatalk
  3. Search for rivet clips or plastic rivet fasteners you may have more luck Sent from my iPhone using Tapatalk
  4. Finally got around to adding some footwell lighting. Added some white to come on with the dome lights and some red for some accent lighting while driving and hooked both up to a dinner switch so I could control how bright I want them Sent from my iPhone using Tapatalk
  5. I just did the rear because of how bad they were but I plan on doing the front too when the extra funds permit Sent from my iPhone using Tapatalk
  6. That’s how I’ve always known them to mount but everything I could find online tells me that Bilsteins are recommended the other way around so that’s how I did it and also mounted this way the labels aren’t upside down so that that has to count for something lol Sent from my iPhone using Tapatalk
  7. Rides 10 times better wish I would’ve done this earlier Sent from my iPhone using Tapatalk
  8. Finally got it back today after getting the damage from the deer fixed Sent from my iPhone using Tapatalk
  9. Had a lovely drive home last night Sent from my iPhone using Tapatalk
  10. I don’t remember how much they were but I have seen lift brackets for the seats on eBay. Unless you find salvageable seats that would be a cheaper route imo Sent from my iPhone using Tapatalk
  11. I had a noticeable vibration that started about 57-58mph but after the clamps I don’t feel a vibration until about 65mph I just hit 59,000 and it’s the first time I’ve changed the filter since I got the truck at 21,000 Sent from my iPhone using Tapatalk
  12. Finally changed the cabin air filter and also added some spring clamps to see if that helped my vibration issue Sent from my iPhone using Tapatalk
  13. Not the biggest fan of the new chevys but I love that combo Sent from my iPhone using Tapatalk
  14. Does it not show in the corner of the radio? Sent from my iPhone using Tapatalk
×
×
  • Create New...

Important Information

By using this site, you agree to our Terms of Use.