Jump to content

MapleBud

Member
  • Content Count

    30
  • Joined

  • Last visited

Community Reputation

0 Neutral

About MapleBud

  • Rank
    Enthusiast

Profile Information

  • Name
    Array
  • Location
    Array
  • Gender
    Array
  • Drives
    Array

Recent Profile Visitors

The recent visitors block is disabled and is not being shown to other users.

  1. Google PIP5570 it’s a bulletin on the problem. Don’t stress man
  2. It’s actually this. There’s a bulletin about it but no recall as of yet. I showed my dealer the bulletin and they replaced without issue, the noise did come back so I opened it up and packed the boot with grease and sound is gone
  3. It was missing, holes were exposed, replaced without issue Sent from my iPhone using Tapatalk
  4. I printed and brought them the bulletin and they had no issues changing it Sent from my iPhone using Tapatalk
  5. Ok so I thought the sound was coming back but I’ve noticed it’s more of a wind sound. It seems my truck is missing weather strip off the drivers door. Sent from my iPhone using Tapatalk
  6. So I got mine done dec 27, and I can faintly hear it coming back. It’s starting to piss me off
  7. How did you grease it? Did you put grease in the boot?
  8. Hi All, So I got the PIP5570A done today on my 17 Sierra, and all noises are gone. I couldn't be happier. It's been driving me crazy for a year and a half. Dealer acknowledged the Bulletin and without question replaced the parts and all were covered under warranty. Feels like I'm driving a new car again. Just for the record, they did say the old boot was not seated properly. I'm in Canada, and dealer had no issues, so all my fellow Canadians who have this issue, go get it fixed.
  9. I find if I shut down the app on my phone while attached to Apple auto then reload the app on the stereo it works. It’s a pain... bigger problem I have is it doesn’t always connect my phone. Sent from my iPhone using Tapatalk
  10. Did you level that beauty. It looks sharp Sent from my iPad using Tapatalk
  11. I’ve got one in my Sierra, it was thrown in because I was requesting undercoating and they stated they no longer offered it. I did some research on it but am still sceptical. One website stated the US Navy uses them on their vessels, of course on a larger scale. My own experience I’ve found my brake rotors don’t rust. Every car I ever owned within hours of washing and sitting in the driveway, the rotors would rust. On my Sierra with this electronic rust protection my rotors have never rusted/oxidized. Sent from my iPad using Tapatalk
  12. You’re lazy Sent from my iPhone using Tapatalk
  13. Yeah it’s illegal Sent from my iPhone using Tapatalk
×
×
  • Create New...

Important Information

By using this site, you agree to our Terms of Use.