Jump to content

Jcollette33

Member
  • Content Count

    16
  • Joined

  • Last visited

Community Reputation

4 Neutral

About Jcollette33

  • Rank
    Enthusiast

Profile Information

  • Name
    Array
  • Location
    Array
  • Drives
    Array

Recent Profile Visitors

The recent visitors block is disabled and is not being shown to other users.

  1. Please excuse my ignorance, but I always wondered what the smaller plug if for. And what’s the long narrow one for that’s inside the center console under the armrest?
  2. My mileage has really dropped of with the winter blend this year. Has was anyone else noticed that?
  3. I’m not sure if they did or not. I just know that it happened to me a year ago when I plugged my truck in when it was 4 deg over night. The remote start wouldn’t work the next morning and when I started it by hand the cel was on and the engine fan was on high. When I took it to the dealership they told me not to plug it in unless it was at the recommended temp.
  4. If you plug it in before the temp is at or below the recommended temp, you could possibly get a CEL and your fan will run on high until the code is cleared or the truck is ran for six or so hrs. Ask me how I know.
  5. Thanks for the update. I was told by others to make sure it’s torqued right because it’s fairly easy to crack the plastic housing.
  6. So if the conversion is right it should be around 19 ft lbs correct?
  7. What’s the torque spec on the housing? I need to replace mine this weekend.
  8. Btw good luck if you need parts. Mine was in the shop for two months waiting on a couple parts and I don’t think that supply is getting any better w the China plague going on. Hopefully your luck is better.
  9. I agree something definitely isn’t right. Whether it’s your display or actually something wrong w your engine you should have it checked. What is the fuel range on your fill up? I have one in the RST trim and I travel roughly an hr or more to work depending on the jobs location. Normally I fill up Monday morning and am good all week. The job I’ve been on for a majority of this year is probably 75% hwy and 25% county rds. On the hwy I’m going close to 70mph and 55-35 on the county rds. My truck averages 26-28 mpg daily. My best ever is 39.1 on an extended drive on a hwy going 55mph. The worst average I’ve had was 22 w a lot of city and idling. Good luck and keep us updated.
  10. Mine did the same thing one time after climbing a hill on the interstate. Then it went back down to slightly above 210 and hasn’t done it since.
  11. If you’re using the ac it won’t shut off I believe.
  12. Well it’s 9/11 and still no parts. I was told the parts distribution centers that’s holding everything up. It’s been in the shop 28 days now. I’ve had to call the dealer every time just to get some kind of half assed an answer. It’s really getting frustrating. Two more days and it’s in Ohio lemon law territory. I really don’t want to go down that road because it’s a giant pain and I’m by far not a litigious person, but man how long do I have to wait?
  13. As of 9/6 still waiting on the parts to fix my 3.0. It’s been in the shop for over 3 weeks now. I realize that it’s a new engine and shipping is a nightmare, so I’m not upset w that, it’s that the dealer and gm has had zero contact w me. I’ve had to initiate every conversation when I can actually get through to someone. It still doesn’t change my opinion of the truck it just makes me miss it more. Plus there’s been numerous times I’ve needed a truck and the Buick Encore and Chevy trax they’ve given me for a loaner isn’t good for hauling much.
  14. 15,000 on mine bought on 1/20/20. Love the truck. Love the mileage. Then two and a half weeks ago started to hear a sound of something under the cab/hood. Looked under good and saw nothing out of the ordinary. Then check engine light came on. Took to dealer. They called and said that there was oil on engine. Wasn’t there before I took it there and must’ve happened on way. Been there two weeks dealer has been communicating w gm w no diagnosis. Then finally got a call from dealer yesterday saying they found the problem. Check engine light was O2 sensors but oil was from a blown seal. Replacing turbo, intercooler and other parts. Parts will be in Monday and truck should be done on weds. Will update when I get the work order When I pick it up. Even w problems still love engine and hasn’t soured my opinion yet. Sorry for hurried reply at kids party. Will update later.
  15. Btw don’t plug it in unless it’s below 0. I plugged min in when it was 6 degrees and it made my check engine light come on.
×
×
  • Create New...

Important Information

By using this site, you agree to our Terms of Use.