Jump to content

Arkie6.2

Member
  • Content Count

    5
  • Joined

  • Last visited

Community Reputation

3 Neutral

About Arkie6.2

  • Rank
    Enthusiast
  • Birthday 07/09/1989

Profile Information

  • Name
    Array
  • Location
    Array
  • Gender
    Array
  • Interests
    Array
  • Drives
    Array

Recent Profile Visitors

The recent visitors block is disabled and is not being shown to other users.

  1. The DFM is currently disabled on the truck. Not sure it’s the cause of the issue. Sent a video to the dealer they said the variation is normal. Not sure if that’s right or not. Will just have to continue to monitor.
  2. Hello, I am getting surging in Rpm of about 100 rpm while driving. Seems to be worse when cold but it is definitely noticeable when between 1,000 and 2,500 rpm. At first I thought it was bad gas but it has persisted. Has anyone else experienced this ? Seems similar to the torque converter issue that people were experiencing with the 8spd.
  3. Friday I changed both the engine oil and the front and rear differential fluid. I went with Amsoil signature 5w-30 with one of the Amsoil filters. and Amsoil Severe gear 75w90 for the differentials. No real changes to report other than I picked up what looks like about 5psi or oil pressure at idle. Time will tell I suppose. Planning to do the transmission and transfer case in the next few months.
  4. Sounds like it is probably just me over thinking it then. It for sure feels different at low speed in sport mode.
  5. Does anyone else’s truck feel like it is in too high of a gear at low speed (15-30 mph)? it almost feels like the truck is lugging (surely it isn’t). Is this just part of the 10spd learning process ? The truck only has 1100 miles on it.
×
×
  • Create New...

Important Information

By using this site, you agree to our Terms of Use.