Jump to content

Brittney Trefry

New Member
  • Posts

    4
  • Joined

  • Last visited

Everything posted by Brittney Trefry

  1. Thanks for the response. Totally sounds like a standard process I would go through lol. Actually those were the steps I planned on taking, so thanks for sharing, it helps me figure out what I should do if I get t wrong. I hope to God it ends up not being the rear main seal!
  2. So I added the uv dye, ran the truck for a bit and did another check. Inside the bell housing looked clean surprisingly. It really appears to be coming mostly from the oil pan gasket AND the valve cover gasket. To answer your question, yes, standard trans. I noticed that the line on the side of the trans had a lot of oil on it. Is that the shift linkage ? I don't think he has oil cooler lines. How would I check for a bad thrust bearing. Thank you for the response
  3. Thanks for the response! So I ended up checking both of those. Unfortunately, neither were the culprit. I was hoping one of them would be, since the alternative is a lot more of a headache
  4. Hi everyone, first time posting, but long time reader. I usually try to avoid posting when I can, and just browse the threads and read about related problems and figure it out from there. Even though I've found many threads that are similar to the problem Im having, I still can't narrow it down to my next step. so if anyone can help, it would be greatly appreciated. Ok so, BAD oil leak problem with my friends 2005 GMC Sierra 1500. It's had this leak for a while, but it's gotten to the point now where it's starting to leave puddles. I power washed the entire area, and I actually got it pretty clean. Today when I looked again to see if I could trace the source, I had a much clearer picture of where the leaks are actually coming from. From what I've read it seems as though it could be the valve cover gasket, the crankshaft sensor, the rear main seal, or even the oil pan gasket. My problem is that to me, it looks like it's coming from almost all these places. I looked inside the bell housing and I don't see it looking completely soaked in oil. It does however, look like the leak is mainly coming from in front of the bell housing behind the engine, in between the two. I'll attach some pictures. These would be from overnight after I power washed it, so the oil hasn't blown anywhere from being driven or anything. Thanks so much to anyone who's got any ideas!
×
×
  • Create New...

Important Information

By using this site, you agree to our Terms of Use.