Jump to content

MattyB4x4

Member
  • Content Count

    15
  • Joined

  • Last visited

Community Reputation

0 Neutral

About MattyB4x4

  • Rank
    Enthusiast

Recent Profile Visitors

The recent visitors block is disabled and is not being shown to other users.

  1. I've seen the Black Bear dyno runs on all of them, but am interested in the S&B setup for my 6.2. Has anyone run dyno tests on the S&B CAI on the 6.2L? I love being able to see the filter and really like the way it looks under the hood, but - looks aren't everything. I'm leaning AFE Momentum w/ a dry filter...simply from the Black Bear dyno runs, but would love to save $100 and run the S&B.
  2. Well, it's the second time this has happened to my bone stock 2007.5 Silveradto WT w/ the 4.8L.... First time, the wiring to the low beam bulb on my passenger side actually melted. I was in a bind and couldn't get the truck into the shop so I ordered a new set of pigtails and spliced newer, thicker wires to the old ones. Now, about a year later, the plastic piece that goes into the headlight bulb has melted. So I replaced the same pigtails again. I tested the headlights, they all work. I put everything back together and now....I have no headlights at all. The only issue I was having was with the passenger side low beam....now, I have nothing. My parking lights work, but no headlights. When I turn the lights from parking light to "on" I hear a click. I've checked all headlight fuses and they are fine. I'm heading out of town on Friday and am totally perplexed. Any troubleshooting, tips would be greatly appreciated. Could a faulty splice job cause both lights to go out? If I lost a ground, could this cause me to lose BOTH headlights? Thanks!
  3. Thank you so so much!!!! I'm working in the dark in my driveway right now. Got everything taken care of but need to run to the hardware store...didn't know what size nuts to get for the two posts on the fuse box. Got it all hooked up, minus the fuse. Does it make sense that I would have power at the controller without the fuse in? I assume that the fuse has to do with the actual trailer brakes and not the brake controller itself? Thanks again
  4. Thank you so so much!!!! I'm working in the dark in my driveway right now. Got everything taken care of but need to run to the hardware store...didn't know what size nuts to get for the two posts on the fuse box.
  5. I just noticed that too. Any way I could get them? Have a trip on Friday and got the controller yesterday. Thanks!
×
×
  • Create New...

Important Information

By using this site, you agree to our Terms of Use.