Jump to content

TripleBGM

Member
  • Content Count

    66
  • Joined

  • Last visited

  • Days Won

    1

TripleBGM last won the day on June 14

TripleBGM had the most liked content!

Community Reputation

32 Good

About TripleBGM

  • Rank
    Enthusiast

Profile Information

  • Location
    Array
  • Gender
    Array
  • Drives
    Array

Recent Profile Visitors

The recent visitors block is disabled and is not being shown to other users.

  1. I have found myself using the MPTG much more than I thought I would. It's very handing for many task.
  2. Stock at4 suspension Black rhino chase wheels 20x9 +10 offset 295/55/20 Nitto Ridge grapplers No rubbing No spacers Sent from my iPhone using Tapatalk
  3. Very nice. I went with the 295/55/20 KO2s but discount tire could not get them balanced so they offered up the ridge grappler’s. I’m very happy with the tire. So I had the stock Duratracs then the KO2s and now the ridge grappler’s. The ridge grappler’s are my favorite of the three. Sent from my iPhone using Tapatalk
  4. Sometimes you may want to place your phone there but not have it charging.
  5. Where did you get this? Sent from my iPhone using Tapatalk
  6. The dealer replaced the SD card reader today, it seems to work fine now. We'll see if it last.....
  7. 2019 GMC AT4 6.2 Thule T2 Bike Rake 2018 Santa Cruz Blur - S Package I like how I can open the bed up with a bike on the rack. I keep finding useful things with this multi pro tailgate. The rearview camera is also nice when a bike is on the rack. Post your set up.
  8. 15 city / 19 highway for me. Not as good as my 2018 5.3 (17/20) but loads more fun.
  9. 4/19 build for my truck, per truck label. I emailed the above to get the build sheet and exact date. Thanks.
  10. The speedo was checked with a GPS app and it seemed to be dead on.
  11. I tried that, nothing. I took it to the dealer, they had to order a new SD card reader. Hopefully that does the trick.
  12. At 200 miles I got an SD card error and navi didn’t work. Dealer replaced the SD card and navi worked until 1500 miles. Now it says SD card removed but it hasn’t been removed and navi does not work. I guess I’m back to the dealer. Sent from my iPhone using Tapatalk
×
×
  • Create New...

Important Information

By using this site, you agree to our Terms of Use.