Jump to content

Chris.Green

Member
  • Content Count

    4
  • Joined

  • Last visited

Community Reputation

1 Neutral

About Chris.Green

  • Rank
    New Member

Profile Information

  • Name
    Array
  • Location
    Array
  • Drives
    Array

Recent Profile Visitors

The recent visitors block is disabled and is not being shown to other users.

  1. I bought a superal flashchips programmer 150 bucks. Plugged it in one time and disabled v4 mode. Has been running great for about 15k miles like that. You can also tune the vehicle for towing or fuel efficiency with the chip, read diagnostics, calibrate tpms and adjust Speedo for bigger tires. The only thing is if the battery gets disconnected you have to go back in and redo it. Still a way better deal for your money than the silly little range plug n play thing.
  2. I sent in an oil sample test to CAT and AMSOIL and they both came back clean. The pickup now has 30k miles on it and runs great. Haven't heard or felt any problems. I just decided that I'm going to take it in to my GM dealer once a year and ask them to look at the same problem. Hoping that they will give me a different answer. I'm bringing it in again this month. But my power train warranty is past the 3 year mark now so fingers crossed.
  3. Thanks guys, I ordered an analysis so I'm just waiting on it to get here. Then I'll change oil and send in a sample. I'll post a pic of the filter if there are any goodies in there when I change it. Appreciate the help.
  4. I bought a 2015 Silverado 1500 lt double cab 5.3L V8 4x4 with 12,000 miles on it a couple months ago. It now has just under 20k miles and when I went to check the oil there where metal shavings on the end of the dipstick. Concerningly big metal shavings. I brought it in to my local GM dealer and they told me that it's from the dipstick scraping on the dipstick tube. They didnt run any tests on it they just drained it and looked in the oil itself and didnt find any shavings (so they said). Which sounded a little shady to me so I started looking to see if anyone else had this problem and I found a few cases similar but not enough for me to come to a solid conclusion. The pickup runs great and I dont hear or feel any problems but any insight would be greatly appreciated. I thought about sending a sample to be tested myself but I dont know of any good company's near me that do it. Any recommendations on that would great too. Thanks
×
×
  • Create New...

Important Information

By using this site, you agree to our Terms of Use.