Jump to content

MagicalOnion

Member
  • Content Count

    11
  • Joined

  • Last visited

Community Reputation

7 Neutral

About MagicalOnion

  • Rank
    Enthusiast

Recent Profile Visitors

The recent visitors block is disabled and is not being shown to other users.

  1. Weird, I also have a Viofo A129 Duo, hardwired into the pass side fuse box, I have no issues at all with any of the TPMS going off or anything similar to you guys, but my camera would not turn on every time, 1 out of 5 times it would not turn on and I have to unplug and plug back the main cable going into the camera to 'reset it'. My parking mode does not work either and can't figure out why. This is the 3rd vehicle I've installed this camera into and Ive never had an issue before, Im thinking of taking it to a shop that installs camera so they can trouble shoot and see if I did something wrong.
  2. Yes, did it myself, never before did any sort of wrap or decal, there are very tiny imperfections but not bad for first time.
  3. My 2021 RST 3.0d. Finished blacking out all the emblems including the Z71, and added GM oem bowtie decal
  4. Installed GM accessory bed decals, has anyone seen another truck with those?
  5. Just finished installing the accessory decals on both sides, turned out decent for first time wrapping a piece this big. Decided to share as I have never seen one of these on another truck before.
  6. I'm just going to find and order a black Z71 emblem for the fender to complete the look of it.
  7. Here you go, I was able to upload them, This is one the way back from the dealership, not even cleaned yet.
  8. I just bought one like that exactly, trying to insert a URL link, but it won't work for some reason.
×
×
  • Create New...

Important Information

By using this site, you agree to our Terms of Use.