Jump to content

TXDenali2015

Member
  • Content Count

    1
  • Joined

  • Last visited

Community Reputation

0 Neutral

About TXDenali2015

  • Rank
    New Member
  1. TLDR version - 2015 Yukon Denali with 20inch wheels and 86k miles. Great ride initially, font struts replaced 3 times for leaking since 50k and ride quality horrible. First post after years of learning from the great people on this forum. Have an early 2015 Yukon Denali which had a lot of the initial growing pains for a new model but nothing major. Fast forward to just past 50k miles and ride becomes bumpy to almost violent at times. Dealer replaced front struts which had begun leaking. Ride improved a little but things like speed bumps would throw everyone side to side as well as parking garages with small imperfections that would bounce you out of your seat at 10mph and lower. Most of my miles are highway and beltway at speeds between 65 and 75. This is where the car feels every bump and seems to react side to side rather than up and down. fast forward to 70k+ and ride has gotten worse. Took to different dealer who identifies front struts leaking again and replaces them under extended warranty. Small improvement at highway speeds, but forget about speed bumps or neighborhood roads or driveways with small imperfections. just hit 86k and have now had the struts fail and replaced for 3rd time since the 50k mark. Ride quality has not Improved and actually believe the side to side motion is worse after hitting a imperfection or small bump. Extended warranty expires at 94k at which time I cannot afford to keep replacing $1800 worth of struts every 10-15k. Reaching out for any suggestions or experiences that might help identify what happened to the ride quality. The service department is at a loss.
×
×
  • Create New...

Important Information

By using this site, you agree to our Terms of Use.