Jump to content

smcgillis10

Member
  • Content count

    510
  • Joined

  • Last visited

  • Days Won

    1

smcgillis10 last won the day on July 2 2017

smcgillis10 had the most liked content!

Community Reputation

217 Excellent

About smcgillis10

  • Rank
    Enthusiast

Recent Profile Visitors

5,707 profile views
  1. Lets See Some Towing Pics!

    This was almost too much for this truck. Lol Sent from my SM-N950U using Tapatalk
  2. What have you done to your K2 today?

    Added Mud flaps, bed storage drawers, new rear axle shafts/bearings/ seals, new driveline goes in today, new shoes for the truck and a thinblueline Sent from my SM-N950U using Tapatalk
  3. What have you done to your K2 today?

    Went the DIY route and added some relay and a spot to add accessory power. Sent from my SM-N950U using Tapatalk
  4. You commented on my other post. I haven't replaced the solenoid yet. Butwhen I do I'll let you know. Sent from my SM-N950U using Tapatalk
  5. I have the same code Sent from my SM-N950U using Tapatalk
  6. Just so ypu know It's not a sensor. It's a pressure control solenoid. Changes the oil system from high to low pressure. I have the parts waiting at the dealer to pick them up. The solenoid is either getting suck or it's failing. The solenoid part number is #12659935 Sent from my SM-N950U using Tapatalk
  7. Factory Engine Block Heater

    Here's some pics Sent from my Pixel XL using Tapatalk
  8. Post Pics of Your 2014+

    No sir. Have had them in for 3 years. No issues. Sent from my Pixel XL using Tapatalk
  9. Post Pics of Your 2014+

    Quick it snowed everyone in the ditch!!! Sent from my Pixel XL using Tapatalk
  10. 2014 5.3 oil pump failure

    Did you ever get this resolved? Sent from my Pixel XL using Tapatalk
  11. When looking this code up on google it's give a bunch of random answers. But the parts store and another forum say it's oil control selenoid. Have any of you delt with this before? Did you end up replacing the oil pump? Or just the selenoid Oil pressure is good and flucuates with throttle. Yes I used the search function. And got nothing. BTW its a 2014 Silverado 1500 5.3l and I have 75500 miles. Sent from my Pixel XL using Tapatalk
  12. Did you ever get this resolved? Did they have to replace just the selenoid or the oil pump also? Sent from my Pixel XL using Tapatalk
  13. Shake or Vibration Issues

    I'll look into that. I am looking at axles because mine are eating rotors. It's wearing them on half of the rotor. Like it's wabbling and touching one side. Sent from my Pixel XL using Tapatalk
  14. What have you done to your K2 today?

    After putting my full replacement on I noticed more and more people will cut me off and pull out in front of me. Sent from my Pixel XL using Tapatalk
  15. Shake or Vibration Issues

    Here ya go. The trucks with the bench and fold down center amplify the shake since there's a lot of flex in how it mounts. Sent from my Pixel XL using Tapatalk
×

Important Information

By using this site, you agree to our Terms of Use.