Jump to content

TeamGoose

Member
  • Content Count

    85
  • Joined

  • Last visited

Community Reputation

16 Good

About TeamGoose

  • Rank
    Enthusiast
  • Birthday 04/19/1984

Profile Information

  • Name
    Array
  • Location
    Array
  • Gender
    Array
  • Drives
    Array

Recent Profile Visitors

2,344 profile views
  1. Still haven’t messed with mine since then.. been too busy and I don’t feel like messing with the Chevy house on what few days I get off working for the railroad. Sent from my iPhone using Tapatalk
  2. I had the same thing happen to my ‘16. I also check the fuses, HMI and disconnected and reconnected the batter and have since change batteries bc the screen would be on but with no display. It would just kind of have a backlit glow. It wouldn’t be like this all the time. Every now and then the backup camera would work. Sometimes the steering wheel controls would work for a bit and I would be able to listen to the radio but those would stop and when I turned my truck off the radio would turn off and eventually it drain my battery. the Chevy house told me they were aware of the issue but wouldn’t warranty it bc it had over 36k on it. So now I’m am looking into just ordering the brains that are behind the screen to see if that’ll work and the a new lcd screen if it doesn’t. the guy at the Chevy house laughed and said he could fix it for $2k. So now I’m just going to find the part #s and do it myself when I eventually get tired of not having a radio. It’s been this way since April.
  3. I can’t get the buttons to work, the only way I can control the radio is with the controls on the steering wheel and that doesn’t even work all the time. Sometimes the radio won’t even come on and when it does it’s a long delay before I here it. Sent from my iPhone using Tapatalk
  4. So I started my truck with the remote start and got In my truck and the screen was off and couldn’t manage to get it to come on nor get my CD (old school I know) to eject. It’s been 2 weeks or so and not having any luck. Every now and then I can change the station and control the volume with the steering wheel controls, but that’s it. No Bluetooth. I have watched several videos on the YouTube. I have replace the fuse and checked to make sure the connections behind the glove box were good. The Chevy house won’t warranty it bc I have 45k miles on it even though I’ve had under 3 years. They said it’d be around $2k to fix it. Just curious if if anyone else has had this issue or know of some way to maybe fix it or an after market system that would be easy to install. Might just say screw and get an AT4 if the wife will let me, but I finally have this truck the way I want it. Please Help.
  5. Looking to get a tool box for my ‘16 Z71. I want something with a low profile. Mainly to get my gear in. And also interested to see any hack hacks that people have done to there tool boxes. Do people put any type of rubber under the sides before mounting it to the side rails of their truck and what do you all use to mount it. I see the hardware they come with, but I have heard of people using different things. Thanks! Sent from my iPhone using Tapatalk
  6. Almost that that it was my brakes/pads were loose or catching when I felt it through the pedals at low speeds and when I came to a stop like something was bouncing around. Sent from my iPhone using Tapatalk
  7. That's what mine sounded like. My would do it randomly, but I felt like I could feel it on my pedals. I might just have sensitive feet lol and or was really looking for something to justify me not being crazy. Sent from my iPhone using Tapatalk
  8. Well got the call from the Chevy house this morning after dropping it off again after showing them the video I took. They said that they are have to order a new strut and it'll take 3-5 days, but is covered under the warranty. So I hope this fixes it. Sent from my iPhone using Tapatalk
  9. Well I took my truck in on Thursday and of course it was making that annoying sound. I test drive it with the guy and then had him drive it, but couldn't replica the sound. I could feel it though, but he "couldn't". Of all things I forgot to show them the video I took before I dropped it off. I showed it to the lady that was handling my paperwork and she said to show that to the service manager next time I come and and to set up another appoint to leave my truck. So we shall see. Sent from my iPhone using Tapatalk
  10. Well I know for sure it's not the leaf springs. I had to deal with that with my '11 Sierra. Every time I back out my drive way which had a little slope to it, I could hear the leaf springs. Back then I had a work truck so it was ok to leave the truck in the shop for a week and a half for them to figure it out and "replace" them. It only had 20k miles on it. As soon as I get this fixed I hope to put my 5100s in all 4 corners. Sent from my iPhone using Tapatalk
  11. Now it becomes a problem of getting my truck in the shop. Every time I call the Chevy place here in town the response is " the soonest we can get you in will be in a week and you'll have to leave it with us for some time." Well that's fine give me a loan bc I need a TRUCK for work. Sent from my iPhone using Tapatalk
  12. Excellent info and thank you! That is exactly what min it doing. Haven't even install my leveling kit yet. Sent from my iPhone using Tapatalk
  13. Excellent info and thank you! That is exactly what min it doing. Haven't even install my leveling kit yet. Sent from my iPhone using Tapatalk
×
×
  • Create New...

Important Information

By using this site, you agree to our Terms of Use.