Jump to content

Sierra Jon

Member
  • Posts

    734
  • Joined

  • Last visited

  • Days Won

    2

Everything posted by Sierra Jon

  1. I understand and agree. I'm just frustrated because they opened the road with the tree branch hanging to begin with lol. Thanks for the reply.
  2. So far so good but we haven't had hardly any snow yet in Boston. Not complaining.
  3. They are excellent for the stock tires. I don't get any slinging on the side of the truck that I've seen. When I go to 35's I may go with a different look.
  4. I find it hard to believe nobody has had to fix a tow mirror on here. No dealer techs on here either? This website used to thrive where did everybody go?
  5. So during the nor'easter I hit a hanging branch that broke my mirror. The only thing that's broken is the injection molded plastic piece (see red arrow). It's essentially the frame of the mirror. I cannot find a way to order this piece separate. Just about every other piece can be ordered... but not this one. (That I can find.) The question is for anyone with experience with these mirrors... Does anyone know if I buy the "cheap" non power version of this mirror will the frame piece that I need be the same?
  6. Installed the magnaflow 12909 and it sounds fantastic. Not super loud but sounds great and has a super deep, low tone. It's in the cab a little at 1500 rpm but it's hardly a drone. Like mentioned above, it sounds like a truck! I posted videos on my Instagram but make sure you use headphones to hear the difference. Videos are here: https://www.instagram.com/sierra_jon_bongo?r=nametag Cheers!
  7. This is cool man. You gotta go visit 0fx2gv Instagram or website and complete this build!
  8. Took a fresh pic the other day. 2021 Denali Ultimate with the L8T. Love this truck!
  9. So Prime "fixed" mine but I have to hit the button sometimes ten times before the thing opens. I usually use my key fob now. SMH.
  10. I don't have experience with AMPs yet but I was referring to the factory power boards. They can't be installed aftermarket (from what I'm told) because there's a switch on the dash to deploy them and they tie into the ECU from the factory.
  11. Yea - they all have their problems... my cousin had brand new Platinum Ford with engine and tranny issues and went and bought a 2021 Ram that turns out to have the "Hemi tick"...
  12. Yea I disconnected it myself when it started happening so that it wouldn't damage itself. That's why i posted those pics above for anyone else having the issue. Bill isn't with Prime anymore. I spoke with the new service manager last time but I'll talk to him again about making this right. That's the most frustrating thing about this all... just make it right. Customer service is so dead (at least in MA). The dealership thinks that because this is a warranty issue that they don't have an obligation to make the customer happy. The free service is sufficient... well that's BS. $60k dollars later and no vehicle for 3 days... that inconvenience should be compensated.
  13. Update: Dealer "fixed" the issue a couple weeks ago. Tech stated they repaired a loose connection. Well the thing started opening again the other day. It's back in the shop today (all day). They didn't finish diagnosis today because they performed an intellilink update and replaced my nicked steering wheel cover - that took 8 hours apparently. I will tell them to contact Central GMC in Norwood for the tailgate issue in the morning. What is a reasonable compensation for warranty issues like this? This will be day three without my truck for this issue and they "don't have any loaners available"... If it weren't for COVID I would be screwed right now with getting to work.
  14. Did you end up looking your light bar with the DRL feature? How is it holding up? This is a clean install! Well done.
  15. A lot of great info on here guys. Thank you! I am going to be installing mine soon and will update here.
  16. Thanks guys. I called ahead hoping they can get the order in. Also, I couldn't take it anymore and disabled the switch. Hasn't happened again since I disconnected it. For me, it was the yellow wire pictured. You need to slide the red tab back in order to depress and unplug the switch.
  17. So I'm having this issue now. For me it's the main tailgate. First it started doing it after I had pressed the button. Clicking/unlocking over and over. Eventually would stop but every time I accessed the main gate by pushing the button it would start again. Truck is going in for it's first oil change Friday. They are going to fix it then hopefully. I'm really surprised that this tailgate came out in 2019 and we're still experiencing this. Very frustrating.
  18. Also following... I'd rather use a blank switch than install the upfitters just yet.
  19. Was looking for these too. Can't find them on GM accessories site.
  20. Have not noticed anything like that so far bud, sorry.
  21. Had anyone done the jumper wire between cargo light switch and reverse lights similar to the K2 mod? Turns the reverse lights on with cargos when the switch is turned on. Thx!
  22. Ok thank you! I had the 12909 on my 6.2 and it sounded amazing but I'm afraid it will be a lot louder on the 6.6.
×
×
  • Create New...

Important Information

By using this site, you agree to our Terms of Use.