Jump to content

EagleRising

Member
  • Content Count

    28
  • Joined

  • Last visited

Community Reputation

2 Neutral

About EagleRising

  • Rank
    Enthusiast

Recent Profile Visitors

The recent visitors block is disabled and is not being shown to other users.

  1. Thanks for the advice, so 2in block it is. I definitely want to most bang for the buck. I'm glad I waited and didn't install lower mount level kit. Those rims look sharp, I have same color. I have to boring silver wheels Sent from my SM-G975U using Tapatalk
  2. Just bought this kit for my 19 LT Z71. I noticed quite a few posts mentioned 2in blocks in back in addition to kit. Just wanted a bit more clarification on this, and what block did you use? I'm assuming 33s won't be an issue after installing Thanks Sent from my SM-G975U using Tapatalk
  3. What kit? I know they sell the 2in TB/AT4 suspension kit. But haven't heard of a level kit Sent from my SM-G975U using Tapatalk
  4. It was a gift, prior to extensive research. That's why it hasn't been installed. But I've seen just as many positive no issue reviews as I've seen negative on lower kits. I have just a standard 19 LT Z71 package so leaning more towards the Bilstein option. Just want to level and get the benefits of better shocks as well. I plan on running 275/70/18s essentially 33s on stock rims. Sent from my SM-G975U using Tapatalk
  5. That's what I have sitting in the garage, a 1.5 in MotoFab lower kit. Just sitting on the fence still Sent from my SM-G975U using Tapatalk
  6. I am interested in this thread. I have a leveling kit(lower) I have been sitting on debating to install it, or wait and do the 5100 package. Sent from my SM-G975U using Tapatalk
  7. I read that, but I can assure I come to a complete stop prior to shifting into gear and acceleration Sent from my SM-G975U using Tapatalk
  8. I have the same problem and got told the same. Everything checks out no issues. Sent from my SM-G975U using Tapatalk
  9. If its passenger area, check your mirror caps. I have the chrome caps and they notoriously rattle at high speeds. I know you said dash area, but just something to check. Sent from my SM-G975U using Tapatalk
  10. Well I learned something new today thanks Sent from my SM-G975U using Tapatalk
  11. Just noticed I have a pin hole in my stock muffler. I was noticing a puddle of water and wasn't running the AC. I'm certain this isn't normal, but please correct me if I'm wrong. I'll see if I can get a picture. Thanks Sent from my SM-G975U using Tapatalk
  12. https://www.gmpartscenter.net/oem-parts/gm-plate-frt-bpr-fascia-skid-chrome-23243083/?c=Zz1ib2R5JnM9YnVtcGVyLWFuZC1jb21wb25lbnRzLWZyb250Jmk9R0gxNDAxMzUmcj01JmE9Y2hldnJvbGV0Jm89c2lsdmVyYWRvLTE1MDAmeT0yMDE5JnQ9bHR6JmU9NS0zbC12OC1nYXM%3D Sent from my SM-G975U using Tapatalk
  13. Im gonna take a guess and say it was some sort of disinfectant or sanitizer. That would definitely cause discoloration if it had bleach or something similar. I could be wrong, but that's my guess Sent from my SM-G975U using Tapatalk
×
×
  • Create New...

Important Information

By using this site, you agree to our Terms of Use.