Jump to content

MY164X4

Member
  • Content Count

    268
  • Joined

  • Last visited

Community Reputation

58 Good

About MY164X4

  • Rank
    EST. 1965
  • Birthday 12/03/1965

Profile Information

  • Name
    Array
  • Location
    Array
  • Gender
    Array
  • Interests
    Array
  • Drives
    Array

Recent Profile Visitors

4,414 profile views
  1. Alarm tracker thats whats up. Which brand? Sent from my SM-N976V using Tapatalk
  2. Looks way better now. Sent from my SM-N976V using Tapatalk
  3. The OEM plugs come pre-gapped (most likely at .040 in). Sent from my SM-N976V using Tapatalk
  4. Good write up thanks. Sent from my SM-N976V using Tapatalk
  5. Check your battery with a multi meter. Sent from my SM-N976V using Tapatalk
  6. I need to add a few more tie downs to the top of the bed, and not sure what to get. Can I get some advice. I have a 500 mile drive 1 way with a king size mattress . Any recommendations. Thanks I got a 2 weeks left before my trip. Here a few pics of my bed.. Thanks fellas and ladies. What type of supplies would you recommend. Thank you. Sent from my SM-N976V using Tapatalk
  7. I'm tracking now. Appreciate the help Sent from my SM-N976V using Tapatalk
  8. Truck is at the dealership now . I guess my faith is in the hands of the mechanic. Sent from my SM-N976V using Tapatalk
  9. Taking the plugs back for replacement. Sent from my SM-N976V using Tapatalk
  10. Can someone tell me if these control arm bushing is serviceable. Truck goes into the dealership Thursday for oil pan gasket leaking. My used truck undercariage is rusty. Truck was purchase in Georgia. 2016 Sierra 77k miles 4x4. Thank you. Sent from my SM-N976V using Tapatalk
  11. Appreciate the knowledge fellas. Thank you. I have 2 plugs gaped at .44. Do I crank them down to .40 or go back to the store and return them for a new set. Since they are OEM. Sent from my SM-N976V using Tapatalk
  12. 2016 Sierra, 5.3L gas, 77k miles Just purchased the AC DELCO 4#41-114 Iridium SP. from AutoZone and the sales rep said they needed to be gap @ .44. This morning I go to check the gap and i see @ .40. I rechecked 3 more plugs and they all are @ .40 So now I'm confused lol any help will be appreciated Thank you
×
×
  • Create New...

Important Information

By using this site, you agree to our Terms of Use.