Jump to content

GMC_SD_Ult_16

Member
  • Content count

    300
  • Joined

  • Last visited

Community Reputation

68 Good

About GMC_SD_Ult_16

  • Rank
    Enthusiast

Profile Information

  • Gender
    Male

Recent Profile Visitors

3,929 profile views
  1. P050D -

    Please get them to put that in writing or at least hurry up and get it in before they change their mind. My 2016 6.2 L got the same code...2 injectors causing the issue and dealer( plus others on this forum) showed me the warranty details specifically excluding the injectors from powertrain warranty. Got GM to cover part of the cost for 4 injectors since I was at 37,000 miles but the fight was not easy and no one would cover it under powertrain warranty. I had them replace all 8 due to a new injector part number that I hoped was updated since mine had been built. I know the powertrain warranty changed from 100k miles (14-15) to 60k miles (16 plus models). Was this another change of powertrain covering injectors (in 14-15 models) versus not covering injectors (in 16+)? Best of Luck. Sent from my SM-N950U using Tapatalk
  2. FS: Lower Sierra Denali Grill 07-13

    Bump Sent from my SM-N950U using Tapatalk
  3. FS: Lower Sierra Denali Grill 07-13

    Bump.. Willing to negotiate the price. Make me a reasonable offer. Sent from my SM-N950U using Tapatalk
  4. FS: Lower Sierra Denali Grill 07-13

    Looking to sale this lower Denali grill. See pics for details. Comes as is. $80 plus shipping costs. This is OEM part and not aftermarket. Part number 15901589. Thanks Sent from my SM-N950U using Tapatalk
  5. WTB: Rear Bumper Assembly 2016 - 2018 K2

    Bump Sent from my SM-N950U using Tapatalk
  6. 2016 Washer Fluid pump quit

    My 2016 was already replaced back at about 30 to 40k miles. Sent from my SM-N950U using Tapatalk
  7. 2014+ Lowering / Drop Kits

    I did the MaxTrac 2 inch lowering shackles and the shock extenders (I did the extenders for my Magneride shocks since they seem to have more issues than many shocks). I decided not to remove the block to see how my truck would handle my 6k# travel trailer. 1 inch rake empty near level with trailer... Had to do a relearn on the Magneride shocks to get them working again properly. All is going well and to me truck rides better than it did stock. Sent from my SM-N950U using Tapatalk
  8. Color: White Frost Tricoat -GMC or Pearl Iridescent - Chevy. 2014 & 2015 did not offer this color as it was slightly different. If you have a mint bumper assembly that is not this color still let me know your expected cost so I can verify the investment to repaint. Location: I am located near Dallas / Ft. Worth. I will pay to ship if needed but would love to find local if available. Condition: Prefer excellent plus (looking for no dings or chips in paint or bumper preferably) My truck is a 2016 Sierra Denali Ultimate with sensors in the bumper as well. Please provide pics if you have something to discuss. Thanks, Michael Sent from my SM-N950U using Tapatalk
  9. Anybody ever have this Issue?

    Well they ended up finding out that it was....... the battery...really.. Happy that is it but disappointed that the O'Reilly's battery testing machine could not produce the same outcome so I could have finished the install myself. Apparently a cell was dead and they said once they installed the new one problem solved... Best news I could have hoped for but sure wasted a lot of time and some money. I did drive a new 2019 SLT loaner for 2 days while they worked to get it into the shop... Long story short it drove really nice but nothing earth shattering to make me want to change over from the "K" style. The 2019 felt so big on the front vs my 2016. I also drove a 2019 Denali with the 6.2L and it felt great as well. The engine/tranny was quick to respond and the 10 speed shifted really smooth. Since my truck is tuned it did not feel better than my current 8 speed but it was definitely better than my 8 speed prior to being tuned. Anyway still can't believe it was a battery but outcome could have been much worse. Sent from my SM-N950U using Tapatalk
  10. Anybody ever have this Issue?

    Interesting on the battery cables mention that is what the service manager said they were going to verify today. As they have had several come in for that issue. I called after he left and they said it moved from the engine group to internal electrical group on the notes. Of course they put me in a 2019 GMC Denali 6.2 to drive while figuring it out... Then the salesperson comes out and is saying I can trade my 16 in for a 19 Denali Ultimate 6.2 and spend $26k out the door... Hmmmmm! Choices... I had just gotten everything where I wanted it on the 16, paid off, etc... Sent from my SM-N950U using Tapatalk
  11. Anybody ever have this Issue?

    I wish I had even gotten that message or any message.... Nothing shows on DIC or radio when I turn the key to start... Battery is reading fine...Since mine is a 2016 I only have the 3 yr 60k warranty but I am just inside both by two weeks and 400 miles. We will see if it is covered. If it is anything like my fuel injectors being replaced or my recent replacement of mageride shock system I don't I will get much warranty. Next vehicle will get extended warranty with all the electronics. Lessons learned. Sent from my SM-N950U using Tapatalk
  12. Anybody ever have this Issue?

    I hope so... I opened that up but did not find anything that was popped... Still scratching my head on this one... Checked fuse boxes as well and found nothing popped. Thanks and I hope you are right. Sent from my SM-N950U using Tapatalk
  13. Today I went out to start my truck and nothing (no starter ticking, no dash lights, no radio screen boot up screen, no running boards extending).... Pulled the battery thinking it was dead and went to O'Reilly's to test it. Nothing wrong with it... Reinstalled battery and still nothing......It started fine the day before...???? Door locks work, dome light works, chime when putting in keys even worked...but not a lot else. Noticed headlights and blinker lights when setting doors to lock blinked strange on front as well but normal in rear tailights. Potentially something wrong with the BCM? Just looking for feedback not complaining.... yet... Owned it for 2 years and 350 days and have 59600 miles. We will see if it fits into any remaining warranty but not planning on it. Had it towed over to dealer so the fun will begin tomorrow. Thanks. Sent from my SM-N950U using Tapatalk
  14. 2017 Truck Build. Whipple install

    Thanks... I am using Tapatalk app to post to the forums and it does not show his sig/info apparently. Did not know that. Sent from my SM-N950U using Tapatalk
  15. 2017 Truck Build. Whipple install

    Is this on a 6.2L or 5.3L? Just making sure as I did not see it noted anywhere. Thanks. Sent from my SM-N950U using Tapatalk
×

Important Information

By using this site, you agree to our Terms of Use.