Jump to content

sierra windshield wiper intermittent problems?


Recommended Posts

Hello, have a 99 sierra which is giving me some issues and need help identifiying the problem.

 

Symptoms:

-intermittent speed setting on windshield wipers doesn't work.

- wipers only work on high

- about a month ago when switched into lets say the middle setting the wipers would swing very slowly 1 or 2 passes and get stuck in the center of the windshield.

-changed the wiper pulse module and no difference

ADDITIONAL NOTES

- DRIVER SIDE POWER WINDOW DOES NOT FUNCTION

-WASHER FLUID DOES NOT SPRAY when twisted into the spray positon

-AC DOESNT WORK

-INSTRUMENT CLUSTER DOESNT SHOW TRANSMISSION SETTING OR MILEAGE

Link to comment
Share on other sites

How would faulty wireing, window motors failing, ac compressors failing be chalked up to "not taking care of the truck over the years"? Should my preventive maintenance include replace all electrical components every 5-7 years due to gm using cheap parts?

Link to comment
Share on other sites

Did all these things crop up at the same time? If so then why did you change a part of the windshield wiper system? If not then you obviously have multiple issues that have been stacking up over time and unless you know how to use a multimeter and have the appropriate schematics you're going to doing what we used to call "swaptronics" in the USAF.

Link to comment
Share on other sites

A/c Low side pressure switch on the drier (from Advanced). If the system has adequate pressure. I had to do this on mine.

Me personally, I would replace the wiper motor. And see if that does the job. They were not that great anyway. See if voltage is there.

Cluster. Those are known for failing it is not if. It is when. The step motors can be replaced when they fail, but yours failed in a different way. GM Might do something for you there, but you can get a replacement reasonably, and it is an easy fix.

 

My .02

 

greg

Link to comment
Share on other sites

Thanks for the help. Iam going to try throwing a new wiper/cruise control switch at to see if it fixes my problem. I can't imagine it would be the motor as it still works on full speed (highest setting )

 

Just getting around to fixing these electrical issues as I have been replacing my rusted cab corners and rocker panels over the last couple weekends and I think they will fail me on the wipers at inspection , and the window(which I have a new reg and motor for). When iam not a full time mechanic on my weekends and holidays, I actually work 60+ hours as a carpenter.

 

God knows when I will be able to get into the nightmares that await me trying to figure out what the hell is going on with my abs and 4wd.

Link to comment
Share on other sites

Archived

This topic is now archived and is closed to further replies.

  • Recently Browsing   0 members

    • No registered users viewing this page.
  • Forum Statistics

    246.8k
    Total Topics
    2.6m
    Total Posts
  • Member Statistics

    334,760
    Total Members
    8,960
    Most Online
    CurtlMarvin
    Newest Member
    CurtlMarvin
    Joined
  • Who's Online   4 Members, 0 Anonymous, 520 Guests (See full list)



×
×
  • Create New...

Important Information

By using this site, you agree to our Terms of Use.