Jump to content

body mounts creaking at low speeds...


Recommended Posts

I Have the body mount creaking?? This got a little worse with the installation of my steps, But was there before as well.. (less then 500 miles on the truck).

 

I was wondering if anyone knows a way to fix the noise? I have read about spraying them or rubbing grease on them but that does not seem to last for the ones who have done that..

My thought is to replace the body mount with the higher end polyurethen mounts?

would the better mounts solve this? if so where to buy them?

 

also where can you buy Rubber Washers? I have read where some people replaced the washers with rubber ones..

 

Please any advice help solutions would be appreciated...

 

Thanks

Link to comment
Share on other sites

not alot of help here, but I remember reading that you needed to white grease the polyurethen body mounts to keep them from squeaking. so probably switching to polyurethen as far as noise goes.

not sure how thick of washers you need, but you can make a rubber washer from an old inner tube (maybe check a farm tire store for one), if you needed something thicker could see if you could cut one out of a side wall.

Link to comment
Share on other sites

Archived

This topic is now archived and is closed to further replies.

  • Recently Browsing   0 members

    • No registered users viewing this page.
  • Forum Statistics

    246.5k
    Total Topics
    2.6m
    Total Posts
  • Member Statistics

    334,275
    Total Members
    8,960
    Most Online
    Screaminfire
    Newest Member
    Screaminfire
    Joined
  • Who's Online   4 Members, 0 Anonymous, 676 Guests (See full list)



×
×
  • Create New...

Important Information

By using this site, you agree to our Terms of Use.