Jump to content

2008 OEM Radio - Half dead??


Recommended Posts

I've got an '08 Sierra with the factory deck (non bose). A few months ago, my radio quits on the left hand side. Very odd. A few weeks later it came back on. A side note is that my door locks quit on the drivers side about a month before this One day I go to get in the truck and the door locks work and the radio worked. They didn't work the next day and haven't worked since.

 

Any ideas on this? I am assuming the radio is the issue. Has anyone run across a common ground issue or anything? Looking for some ideas to check out. When it warms up, I'll probably hook up a known good radio to test the speakers and isolate the problem.

Link to comment
Share on other sites

I would bet you have something shorting in the harness to the Driver door. Probably right where it enters or exits the boot between the door and the A pillar

 

I second this – that's probably all it could be.

Link to comment
Share on other sites

gmintimidator,

 

Hey there! I understand that you are seeking advice from your fellow forum members on how to resolve this vehicle issue yourself. I might not be able to give you any technical advice but if you find your cannot resolve this issue yourself, I am happy to look into this concern for you. Please private message me if I can be of any assistance.

 

Jennifer T.

GM Customer Care

Link to comment
Share on other sites

I have the exact same problem with my 08 Sierra. Both left door speakers are out. I have pulled the door panels and there are no frayed wires. Pulled the radio out and no frays on the wires there also. I was thinking the radio itself is the problem.

Link to comment
Share on other sites

  • 2 weeks later...

I had same issue a couple of years ago, turned out to be a bad speaker, fixed by dealer. They initially thought radio, but it was a bad speaker. Hope this helps you! SJS

 

Thanks, Never thought of doing that. I am going to have to try to swap the speakers from the right side and see if they work. If they do, guess I will just buy all new speakers and upgrade.

Link to comment
Share on other sites

  • 3 months later...

I finally took some time to tear into this. The wiring looks ok in the door. The mirrors work and the door locks work for the passenger side. The drivers door lock and speaker do not work. Although both worked at 2 different times last week. I had door locks 1 night and all my speakers the next and then neither work again. I've checked the wiring and undid and redid a connection at the fuse block but no luck. It's just odd as the mirrors work.

 

Is it possible the fuse block has a circuit board issue?

Link to comment
Share on other sites

Did some more investigation. I can't get the speaker to work, yet another speaker from my shop stereo works with the trucks wiring. No tears in the speaker, no crunching when moving the cone.... so odd. Atleast if I blew the speaker and it was damaged would be ok. The speaker looks perfect, just doesn't work. It's wierd that it came on the other day, oh well, coil must be fried.

Link to comment
Share on other sites

Archived

This topic is now archived and is closed to further replies.

  • Recently Browsing   0 members

    • No registered users viewing this page.
  • Forum Statistics

    246.8k
    Total Topics
    2.6m
    Total Posts
  • Member Statistics

    334,735
    Total Members
    8,960
    Most Online
    Dustin Regimbal
    Newest Member
    Dustin Regimbal
    Joined
  • Who's Online   4 Members, 0 Anonymous, 415 Guests (See full list)



×
×
  • Create New...

Important Information

By using this site, you agree to our Terms of Use.