Jump to content
  • Sign up for FREE! Become a GM-Trucks.com Member Today!

    In 20 seconds you can become part of the worlds largest and oldest community discussing General Motors, Chevrolet and GMC branded pickups, crossovers, and SUVs. From buying research to owner support, join 1.5 MILLION GM Truck Enthusiasts every month who use GM-Trucks.com as a daily part of their ownership experience. 

2016 Yukon Denali Electrical Problems


Recommended Posts

Vehicle has lost battery power a few times over night the last few weeks.  Known by having to reset clock and recalibrate windows up and down. I have never had to charge the battery. Starts right up.  Today when turning tight,  I would lose power steering for a moment and the gauges would flick off and back on followed by a service stabilitrack message.  Is this a battery or a ground issue? 

Edited by Westernstar23
Added details
Link to comment
Share on other sites

Checking the cables for intermittent voltage issues is always a good idea.

 

Check all the grounds, something could be loosing continuity, just so happens you were driving when it happened. 

 

Look at circuits and grounds for interior - instrument cluster, clock. There is likely another code related to steering sensor, it lost power/ground too and triggered the power steering issue and service stabilitrack.

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.



×
×
  • Create New...

Important Information

By using this site, you agree to our Terms of Use.