Jump to content
  • 0

Cruise control disengages - hard lockup


Blackmore

Question

Hi all,

 

I have a '95 GMC K2500 Suburban with the 6.5TD.

 

I'm having a weird problem, propably related to bad connections but I'd like to know your opinions.

When driving off, and engaging cruise control, it sometimes disengages after about ten minutes of driving.

Sometimes when trying to engage the cruise control after ten minutes of driving, it won't.

I notice a hard shift when locking up also.

Almost always it can be cured by shutting off power and restarting.

Then the cruise control works fine and lockup also works fine and smooth.

Another weird problem is that sometimes, but not as often as the cruise control, the tranny won't shift to from second to third.

Again this can be cured by cutting power and restarting.

Does anybody have any idea where I should start looking.

 

Can anybody tell me where to find a good manual, since their almost impossible to find over here in Belgium.

 

 

Thanks

Link to comment
Share on other sites

0 answers to this question

Recommended Posts

There have been no answers to this question yet

Archived

This topic is now archived and is closed to further replies.

  • Recently Browsing   0 members

    • No registered users viewing this page.
  • Forum Statistics

    246.5k
    Total Topics
    2.6m
    Total Posts
  • Member Statistics

    334,358
    Total Members
    8,960
    Most Online
    Angelm_0819
    Newest Member
    Angelm_0819
    Joined
  • Who's Online   3 Members, 0 Anonymous, 724 Guests (See full list)



×
×
  • Create New...

Important Information

By using this site, you agree to our Terms of Use.