Jump to content
  • 0

12V Outlets in Silverado


sincityZ71

Question

GM-Tech or anyone else,

 

Okay. Slowly over the past month my outlets have been dying. Finally today I went to plug an adapter into the last working one left, heard a little buzzing sound for about 2 secs and it died. The other two died at some time, not really sure when. I have never really used them all that much, only when I took a couple of long trips, and then only to charge my phone when needed. So I am a bit disappointed. Any ideas on what may be the cause?? I am going to check the fuses, but since they seemed to die one at a time I am a little lost as to what caused it.

 

Thanks for your help.

Link to comment
Share on other sites

0 answers to this question

Recommended Posts

Well they were all dead. The fuses where all blown for the three outlets, so I had to go under the hood and replace the cigar and aux outlet fuses. Did a test with my dads truck and determined that there is a problem with one of my adapters, when you plug it into and outlet, the fuse in the truck blows...haha...so I had to replace his fuses too... :) So now I need to see what is up with the one adapter...

Link to comment
Share on other sites

The most likely cause is whatever you're plugging into them. The aux sockets are of a very simple (and durable) design and don't fail that I've ever seen. There are no moving parts, so I don't see them being at fault.

 

The only thing we ever see wrong is a blown fuse caused by a poorly designed adapter.

Link to comment
Share on other sites

Well I will have to check all of that out tomorrow then. I tried 4 different adapters and none of them worked in any of the three outlets, so maybe there is a fuse problem. Just weird how they seemed to stop working one at a time.... :)

Link to comment
Share on other sites

Archived

This topic is now archived and is closed to further replies.



×
×
  • Create New...

Important Information

By using this site, you agree to our Terms of Use.