Jump to content
  • 0

exhaust rattle


Mattt

Question

Ive got this annoying rattle from my exhaust. I crawled under the truck and can see where its coming from, but cant fix it. Middle of the truck near the cats, there is one pipe with a flanged connection, and another with a slip fit connection with a band clamp. Rattle is coming where the clamp is. No matter how tight I get it, rattle is still there. I had my local Chevy dealer take care of it a while back. It went away for a while, but came back. On the R/O they put, tightened midship exhaust(poor design).

 

Anything I can do to fix once and for all?

 

Thanks in advance.

Link to comment
Share on other sites

0 answers to this question

Recommended Posts

Ive got this annoying rattle from my exhaust.  I crawled under the truck and can see where its coming from, but cant fix it.  Middle of the truck near the cats, there is one pipe with a flanged connection, and another with a slip fit connection with a band clamp.  Rattle is coming where the clamp is.  No matter how tight I get it, rattle is still there.  I had my local Chevy dealer take care of it a while back.  It went away for a while, but came back.  On the R/O they put, tightened midship exhaust(poor design). 

 

Anything I can do to fix once and for all?

 

Thanks in advance.

 

 

 

 

It is probably the o2 sensors. They are known to rattle.

Link to comment
Share on other sites

I don't know of any specific rattles we have in the exhaust on those.  Yeah, seen some o2's rattle, but it's a real light, tinny rattle.  More like a ringing type sound.

 

 

 

 

Don't mean to hijack the thread, but I've been hearing what sounds like a small chain being dragged underneath. I guess kind of a ringing-chain link sound...not really loud though.

Wonder if this is o2 related?

 

Sorry again :thumbs: , Didn't mean to butt in :P

 

t

Link to comment
Share on other sites

This is sort of a light tinny rattle, and its only when the engine is loaded. Going up a hill you notice it, Aso going in reverse from a stop.

 

The slip fit is where its coming from. The band clamp seems to be permanently fixed in position. Its as tight as it will go with a 1/2" drive ratchet and still loose enough to rattle. Any fix out there?

Link to comment
Share on other sites

Archived

This topic is now archived and is closed to further replies.



×
×
  • Create New...

Important Information

By using this site, you agree to our Terms of Use.