Jump to content

USAFRET

Member
  • Content Count

    51
  • Joined

  • Last visited

Community Reputation

11 Good

About USAFRET

  • Rank
    Enthusiast

Profile Information

  • Location
    Array
  • Gender
    Array
  • Drives
    Array

Recent Profile Visitors

3,370 profile views
  1. Mine went back to the dealer Monday on a rollback for the second time with this issue. I also informed them of this problem but still have not got my truck back. I also told them I wanted a new battery since this was the second time and this time the battery was drained down to 2 volts.
  2. I had the same problem when I first got my new truck. I had to pull the SD card out and reinstall it. After I did that I had no more issues with the speed limit not showing.
  3. This worked just fine on my trailer tires after i had the sensors installed.
  4. I just did a dealer trade with mine last Thursday (2020 GMC AT4 Duramax). They had problems with some of the other dealers answering calls but finally located one and made the deal.
  5. It looks like the reveal for the 2021 Tahoe/Suburban os set for 12/10/19 http://gmauthority.com/blog/2019/11/all-new-2021-chevrolet-tahoe-and-suburban-will-be-revealed-december-10/
  6. I bought one from a Chevrolet dealer on EBay and had the module in 2 days, here's the link. https://www.ebay.com/itm/253405415313?ul_noapp=true
  7. Got my truck back tonight. They did a triple fluid flush and said this should fix the problem. Still not very optimistic. They also put on the paperwork to drive 2 cold to hot cycles and at least 200 miles and then reevaluate to see if problem was fixed. Shouldn't they have done this before they gave me the truck back?
  8. Mine was just dropped off at the dealer today for the same thing. This is it's second trip for the same problem within a month. The first time it was in they did a reprogram of the computer. Seemed ok for a week and it started all over again. They told me today that they would keep it for several days to come up with a solution...didn't even want to hint this time what they would try.
  9. You didn't mention the engine size in your truck. Mine is a 2016 with the 6.2 and 8 speed and it did the same thing 3 weeks ago at 22,000 miles. Took it into the dealer thinking it was the torque converter as well. All they did was a software update and I haven't had any issues since...keeping my fingers crossed.
  10. GET IT! I would never go back to my old 5.3.
×
×
  • Create New...

Important Information

By using this site, you agree to our Terms of Use.