Jump to content
  • Sign up for FREE! Become a GM-Trucks.com Member Today!

    In 20 seconds you can become part of the worlds largest and oldest community discussing General Motors, Chevrolet and GMC branded pickups, crossovers, and SUVs. From buying research to owner support, join 1.5 MILLION GM Truck Enthusiasts every month who use GM-Trucks.com as a daily part of their ownership experience. 

Recommended Posts

Ok guys and gals. I have a 94' blazer with the 350 TBI and this problem has started a week ago. It would die when at operating temp and at idle with no load on the engine. I concluded the ignition control module. After replacing that, the engine would stall only at idle with a load. With the symptom seeming to be improving, I found the idle air control was out of range (a-b @ 83ohms) so I replaced that. The problem has not changed at all. At idle and with a load she hesitates and dies, almost like it's a fuel delivery problem. Only engine modifications is a set of headers and a throttle body spacer, ( both where on when I bought it in August.) My manual says it could be the ECM. So before I let this beloved truck sit until I can afford one I figured I'd get on here and see if anyone could inform me of anything else it could be. When running, there is no hesitation or lag, strong truck and strong responses. She has 180k+ on the odometer.

  • Like 1
Link to post
Share on other sites
  • 2 months later...

Ok guys and gals. I have a 94' blazer with the 350 TBI and this problem has started a week ago. It would die when at operating temp and at idle with no load on the engine. I concluded the ignition control module. After replacing that, the engine would stall only at idle with a load. With the symptom seeming to be improving, I found the idle air control was out of range (a-b @ 83ohms) so I replaced that. The problem has not changed at all. At idle and with a load she hesitates and dies, almost like it's a fuel delivery problem. Only engine modifications is a set of headers and a throttle body spacer, ( both where on when I bought it in August.) My manual says it could be the ECM. So before I let this beloved truck sit until I can afford one I figured I'd get on here and see if anyone could inform me of anything else it could be. When running, there is no hesitation or lag, strong truck and strong responses. She has 180k+ on the odometer.

I have a 891500 gmc blazer it is doing the same stuff i have changed everything but the throttlebody and the fuel filter and the fuel pump i was wondering if the computer would be the problem can you help if you find out any thing

Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.



×
×
  • Create New...

Important Information

By using this site, you agree to our Terms of Use.