Jump to content
  • Sign up for FREE! Become a GM-Trucks.com Member Today!

    In 20 seconds you can become part of the worlds largest and oldest community discussing General Motors, Chevrolet and GMC branded pickups, crossovers, and SUVs. From buying research to owner support, join 1.5 MILLION GM Truck Enthusiasts every month who use GM-Trucks.com as a daily part of their ownership experience. 

Possible ECU problem? I’m clueless, maybe you can help..

Recommended Posts

Hey! I can manage the basics of a vehicle but this is beyond me..

So starting Monday, I went to start my 2016 Silverado using the fob and nothing was happening. Great, I’m thinking the battery is dead somehow even though I just replaced it less than a year ago. So I go out and start it with the key. The screen flashed and said “2 keys programmed”. I thought that was strange but everything worked normally on the way to work and on the way home, so I thought it was just a weird fluke.


Tuesday was fine…Wednesday I had to start the car with the key again. Everything was fine after that.


Thursday, I had to start it with the key and everything was fine on the way to work. On the way home, my truck was possessed. Lights flickering, AC shutting down or dying way down, a handful of times the truck just died on the highway..like shut down - no lights, no power steering, music, everything shut down - then it would pick back up again by itself after a second.


I got it home, popped the hood and checked the battery terminals..everything was clean and tight. Started it up again and it said “engine power is reduced” on the dash. I wanted to go for a quick test drive to see what that meant, but upon shifting into reverse, I had no throttle response whatsoever.. it didn’t even register the pedal being pressed.


Now I’m nervous, so I run inside and start googling. I saw a few people with similar problems and others telling them to get their ECU reflashed. I ran outside one more time just to test things out, and this time the “engine power is reduced” message didn’t pop up, and the throttle worked just fine..but I didn’t want to risk taking it for a drive so I left it be for now.


Anyone have any clues? Sorry if there is already a post on this, I have no idea what to search because this seems so involved.



Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


  • Create New...

Important Information

By using this site, you agree to our Terms of Use.