Jump to content

wiper problems


Recommended Posts

one cold morning i started my truck with ice on the winshield

my wipers were on and by the time the ice melted the wipers

would only work on high any suggestions to what to replace to

fix the problem my stealer wants 50.00 dollars to just find the

problem plus parts and labor to fix can anyone help me

Link to comment
Share on other sites

  • 7 months later...
I would love to know how this issue was resolved.  Currently, I have the same problem.  I have looked in the tech articles and didn't see anything.

 

Thanks

 

 

 

 

 

this was my problem. this little site helped me fix it too! i was amazed that re-soldering the raceways on the circuit board actually fixed it!!!! hope this helps...

http://members.aol.com/jixix/wipers/WiperFix.htm

Link to comment
Share on other sites

  • 2 months later...

I had the exact same problem on my 1993 W/T 1500, and this problem seems to be inherent to many year models of Chevys with this type of wiper motor. My wipers started to work only intermittently on low, sometimes not at all, and would only run continuously on high. If you don't want to go the route of trying to repair the pulse board with the solder fix, you can just buy a new pulse board at most any auto parts store.

 

I think I paid $25 or $30 for a new pulse board. Put it in, and wipers have worked flawlessly since. Good luck.

Link to comment
Share on other sites

Archived

This topic is now archived and is closed to further replies.



×
×
  • Create New...

Important Information

By using this site, you agree to our Terms of Use.