Jump to content

Gas mileage getting reeeeeeal bad


Recommended Posts

Over the past week or two I have noticed my mileage dropping. I am getting about 30 to 40 per qtr tank. No MIL light. I have also noticed a slight power drop, but not all the time. Some days it runs like hell, some it feels like a dog. Any suggestions?????

Link to comment
Share on other sites

I have checked the Regulator and see no fuel it the line.

 

I have a Diag program for my laptop. The question is, what should the voltage from the O2 sensors be if they are functioning properly?

 

Also I have cleanded the MAF sensor with electronics cleaner, should my idle etc. change when it is unplugged??? I unplugged it to see and there was no change. I had the reset the MIL light with the program after though.

Link to comment
Share on other sites

I have checked the Regulator and see no fuel it the line.

 

I have a Diag program for my laptop. The question is, what should the voltage from the O2 sensors be if they are functioning properly?

 

Also I have  cleanded the MAF sensor with electronics cleaner, should my idle etc. change when it is unplugged???  I unplugged it to see and there was no change.  I had the reset the MIL light with the program after though.

 

 

 

 

The PCM will revert to Speed Density mode with the MAF unplugged and it will run and idle good. The O2 sensors should oscillate(rich-lean) quite a bit. They don't stay at a constant voltage.

Link to comment
Share on other sites

Over the past week or two I have noticed my mileage dropping.  I am getting about 30 to 40 per qtr tank.  No MIL light.  I have also noticed a slight power drop, but not all the time.  Some days it runs like hell, some it feels like a dog. Any suggestions?????

 

 

 

Is your water temp getting up to full temp or staying in the low range ? Maybe somebody is stealing your gas/playing a trick on you, maybe they will put it back next week and you mileage will go to 22..
Link to comment
Share on other sites

Truck is stock.  I don't think anyone is take gas out of the truck.  I am going to hook it up at some point this week and see what the O2 sensors are reading.

 

 

 

Had almost same probelm with brand "F"...thermostat was stuck open and water temp never got above 160F so ECM never went into closed loop.
Link to comment
Share on other sites

Here is what my Diag software got me

 

O2 Sensor Bank 1 Sensor 1 .100 v to .760 v up and down

O2 Sensor Bank 1 Sensor 2 .690 v to .700 v up and down

 

O2 Sensor Bank 2 Sensor 1 .075 v to .805 v upa and down

O2 Sensor Bank 2 Sensor 2 .160 v to .805 v up and down

 

MAP Sensor 42 Kpa

 

MAF Sensor 6 g/s

 

Coolant Temp 92 Celcius

 

Intake Temp 69 Celcius

 

Spark Advance vaires from 16 to 20 degrees

 

Absolute Throttle position between 6 and 7 percent

 

Longterm Fuel Trim 1 -3%

Longterm Fuel Trim 2 -2%

 

Do these look within specs????

Link to comment
Share on other sites

Archived

This topic is now archived and is closed to further replies.



×
×
  • Create New...

Important Information

By using this site, you agree to our Terms of Use.