Jump to content

l.e.d rear light bar?


Recommended Posts

I bought a l.e.d light bar made by rampage, it will not work correctly on my 07 old body style g.mc truck, tried it on 6 other trucks ranging in years from 2000 to 2006 same results , problem is no running lights and when the left siganl is on the whole bar blinks, everyhing else works, it connect to the rear trailer plug, tried it on any truck 2007 and newer with the new body style and it works perfect, i performed all the proper checks at the plug and everything works fine, why would it work on a new truck and not mine , the plug configuration is the same?Trucks and stuff says it works for 1999 and up so i,m really confused, i even thought maybe it was the ground and tried a remote ground with the same results! anyone one had similiar problems, rampage l.e.d light bar model 960136.

Link to comment
Share on other sites

Sounds like an issue with the bar. The 4-pin trailer plug is a industry standard, been around for ages. That bar should power up on anything with the flat-4 conector.

Link to comment
Share on other sites

Sounds like an issue with the bar. The 4-pin trailer plug is a industry standard, been around for ages. That bar should power up on anything with the flat-4 conector.

 

thing is it works on any newer style truck, they won,t take it back because it in fact does work, just not on a 2000 to 2007 older body style truck?
Link to comment
Share on other sites

Sounds like an issue with the bar. The 4-pin trailer plug is a industry standard, been around for ages. That bar should power up on anything with the flat-4 conector.

 

thing is it works on any newer style truck, they won,t take it back because it in fact does work, just not on a 2000 to 2007 older body style truck?

 

 

 

Yeah, I misread what you wrote, sorry. But the fact still stands that there is no reason it shouldn't work on anything with the normal flat-4 connector, be it a Chevy or a Ferrari. After re-reading your post I'd agree with the poster above me that you might have a wiring issue. If you don't have access to a trailer, a place like Canadian Tire may have a tester that can plug in to your truck and basically simulate a trailer (it will have lights for brakes and turn signals on in a small plastic box that plugs into the truck).

Link to comment
Share on other sites

PLug is working as it should, i tow regularly with it, had it been a issue with just my truck, then maybe but 8 trucks now ranging from 2000 to 2007 old body style as well, i even checked them just to be sure, i manually tested the light bar itself and it works fine as well, really stumped and frustrated, its just a 4 wire trailer plug with a extra wire to hook up the reverse light feature, this is really turning out to be a mission now as i really need to know why this won,t work lol!

Link to comment
Share on other sites

  • 2 months later...

Archived

This topic is now archived and is closed to further replies.



×
×
  • Create New...

Important Information

By using this site, you agree to our Terms of Use.