Jump to content

Recommended Posts

Hey guys, I had this indash dvd player installed for sometime and its always worked great. I have a 100watt mono amp hooked up to a 8" sub. I just added a cb radio to my truck and it worked great with everything, I then added a amp to the cb radio and now I get a error code and the radio goes into safe mode. This only happens sometimes. the code is "miswiring dc offset" So this code only comes up when I talk on the cb. I wonder if the amp is drawing to much and causing the voltage to drop and the radio to go into safe mode? anyone have any ideas?

Link to comment
Share on other sites

All the grounds are good. The linear amp is hard wired to the battery with #8syou the indash is factory wired with a plug and play harness. My power inverter and sub amp are wired to the battery with #4s. I hallve dual 1000ca batteries ... and on and on. Ill grab some pictures tonight.

Im a electrician so I like to wire stuff.

Link to comment
Share on other sites

Yes. I had the radio ( uniden pc68xl ) peaked and tweaked to 25 watts and the dead key raised. When I got the linear I had the dead key dropped. Its a nice setup I have a 1.3 at channel 1 and 1.1 at 20 and 1.2 and 40. Once I get some extra cash im going to get a sideband.

 

Connected by DROID on Verizon Wireless

Link to comment
Share on other sites

Archived

This topic is now archived and is closed to further replies.



×
×
  • Create New...

Important Information

By using this site, you agree to our Terms of Use.