Jump to content
  • 0

Autoride compressor runs briefly every ignition cycle. Normal? All ne


jjsche4

Question

I have a 2008 Tahoe LTZ. Struts, air compressor and air lines were all just replaced by dealer but the compressor still turns on for a couple seconds every time I start the car even when there is no weight in the back. Some people told me this is normal, some say its not. I know the later year ones don't do this so i'm wondering if this is in fact normal for 2008's or not and if there is anyway to stop this because it just seems like useless wear on the compressor.

 

Thanks

John

Link to comment
Share on other sites

2 answers to this question

Recommended Posts

Out of curiosity, what does the owners manual say about it? Keep in mind that a compressor that just sits for long periods of time without running does more damage to itself than running for a few seconds on every power up of the vehicle. Are you sure it is not the fuel pump you are hearing?.

Link to comment
Share on other sites

Archived

This topic is now archived and is closed to further replies.

  • Recently Browsing   0 members

    • No registered users viewing this page.
  • Forum Statistics

    246k
    Total Topics
    2.6m
    Total Posts
  • Member Statistics

    333,451
    Total Members
    8,960
    Most Online
    MRDEE
    Newest Member
    MRDEE
    Joined
  • Who's Online   3 Members, 1 Anonymous, 824 Guests (See full list)



×
×
  • Create New...

Important Information

By using this site, you agree to our Terms of Use.