Jump to content

New user with a couple issues


Recommended Posts

Hello, I just bought my first GMC Sierra 1500, its a 2003 extended cab 4X4. it has a couple issues.

 

1. brake lines are rusted, I bought the set and plan to change them this weekend (i know its a big job).

 

2. the service airbag light is on, I pulled the code and found a broken wire under the passenger seat. Does anyone know where the wires are supposed to connect to? is the plug in the picture supposed to be plugged into anything?

 

3. Check engine light is one, I have the following codes, P0131 & P0300. I assume i need to change the o2 sensor near the manifold. Any adivce? i think i heard that you should use OEM and not Bosh.

 

Thanks

 

post-151070-0-64876200-1449814140.jpg

post-151070-0-64876200-1449814140.jpg

post-151070-0-64876200-1449814140.jpg

post-151070-0-64876200-1449814140.jpg

Link to comment
Share on other sites

I had to replace one of the O2 sensors on my 04Yukon.

I just went to A-Zone and got the recommended one. Installed it and all has been good for about 4k miles.

 

As for the wiring you should get the electrical schematic.

Your photo shows two wires disconnected. Find the place on the connector where there are missing wires. Then look at the opposite side and see if the wire there matches the color of the other wires.

Link to comment
Share on other sites

Archived

This topic is now archived and is closed to further replies.



×
×
  • Create New...

Important Information

By using this site, you agree to our Terms of Use.