Jump to content
  • Sign up for FREE! Become a GM-Trucks.com Member Today!

    In 20 seconds you can become part of the worlds largest and oldest community discussing General Motors, Chevrolet and GMC branded pickups, crossovers, and SUVs. From buying research to owner support, join 1.5 MILLION GM Truck Enthusiasts every month who use GM-Trucks.com as a daily part of their ownership experience. 

flashran

15 Yukon SLT heated seat issues

Recommended Posts

So Ive thought about tackling replacing the seat heat element by myself (the driver side is not working at all and passenger side the the lower is not working though the back one is not really getting hot...)

 

A few days ago I've got the new element and plugged it in the connector under the seat (before I'm taking everything apart). Turned on the heat on highest setting and the element got only luke warm (left it for 10min with no much of a change)

 

Having this under the leather cover of he seat I will barley feel it. Could this indicate another issue? Is there a module under the seat that might be the issue?

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.




×
×
  • Create New...

Important Information

By using this site, you agree to our Terms of Use.