Jump to content
  • Sign up for FREE! Become a GM-Trucks.com Member Today!

    In 20 seconds you can become part of the worlds largest and oldest community discussing General Motors, Chevrolet and GMC branded pickups, crossovers, and SUVs. From buying research to owner support, join 1.5 MILLION GM Truck Enthusiasts every month who use GM-Trucks.com as a daily part of their ownership experience. 

Recommended Posts

Posted (edited)

Looking for some help. I have an 87 2wd pickup that has a new engine and transmission in it. It ran fine for the first year then started having issues. Started with rebuilding throttle body with new injectors. Then put in a new distributor with a new coil. New fuel pump and filter. Truck doesn't even idle. Starts up and shuts down. Passenger side injector sprays when it wants to. Changed injectors again with same result. Installed new chip in ecm and same results. Checked and replaced all grounds. Just tired of putting money into it with same results.

Edited by Cladiesel
Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.



×
×
  • Create New...

Important Information

By using this site, you agree to our Terms of Use.