Jump to content

2013 GMC Yukon Denail 6.2L Stuck Lifter


Recommended Posts

Yea, I took it out yesterday.  Apparently when I put it back in the new valley pan I didn't seal the threads.  I wrapped it with Teflon tape, put it back in, roughly clean the stuff under the car with brake cleaner and took it for about a mile test drive and had a little more oil pressure (was right below 40 from a cold start, now its right above 40) then let it sit overnight.  I checked this morning and it looks like there may have been a few drops from the front seal which I know about but not a stream like before in the middle of the truck.   I included pictures of what it look like around it before and after.  I'll take it on a longer drive later and make sure everything is good to go.  Now to figure out the front seal.  Baby steps! Haha

20211102_160638.jpg

20211102_222332.jpg

Edited by Erick C.
  • Like 1
Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

  • Recently Browsing   0 members

    • No registered users viewing this page.
  • Forum Statistics

    246.8k
    Total Topics
    2.6m
    Total Posts
  • Member Statistics

    334,775
    Total Members
    8,960
    Most Online
    moe ali
    Newest Member
    moe ali
    Joined
  • Who's Online   5 Members, 0 Anonymous, 588 Guests (See full list)



×
×
  • Create New...

Important Information

By using this site, you agree to our Terms of Use.