Jump to content

1999 Silverado 2500 with P0446 code


Recommended Posts

Hi,

I have a 1999 Silverado 2500 6.0L 4L80E Ext Cab Longbed ... It recently had a P0446 Evap vent code.. I had the dealer change out the Evap Vent Solenoid with a AC kit #19258957 Evap Vent (GM dealer suggested this as the right one..)replacement kit... It ran good for a month and a half and then the same code( P0446) came back again.... Is there another or more Vent Solenoids on this truck...?

I'm going to replace the Purge Solenoid, in case its stuck... Could it be the PCM..? I hope not... I'll be checking for 12 volts at the connector to the Evap vent harness...

I also checked that the ENG 1 fuse is good; it feeds power to the Vent solenoid....

Any suggestions guys...?????????

Link to comment
Share on other sites

Hi,

I have a 1999 Silverado 2500 6.0L 4L80E Ext Cab Longbed ... It recently had a P0446 Evap vent code.. I had the dealer change out the Evap Vent Solenoid with a AC kit #19258957 Evap Vent (GM dealer suggested this as the right one..)replacement kit... It ran good for a month and a half and then the same code( P0446) came back again.... Is there another or more Vent Solenoids on this truck...?

I'm going to replace the Purge Solenoid, in case its stuck... Could it be the PCM..? I hope not... I'll be checking for 12 volts at the connector to the Evap vent harness...

I also checked that the ENG 1 fuse is good; it feeds power to the Vent solenoid....

Any suggestions guys...?????????

You take it back unless you told them what to do !!! If you did then you get a "fail" ,

 

never call a PCM unless diagnosed ,

 

Code has to be gone thru step by step

Link to comment
Share on other sites

kstruckcountry.... No.... I never have driven on the dirt.... Could the new vent solenoid be bad...? I'll test it as soon as I can get out to it... I live in an apartment, so they hate anyone working on their stuff....

The vent is supposed to run after 3 "good" drives, ones that it sees fit are real trips.. I don't really drive it that much... It's only got 71,000 miles... And I have had it since 2004 when I bought it with 63,000 miles on it...

I wouldn't think it would go bad so soon.... Hmm....

Link to comment
Share on other sites

Govtech4... I'd like to take it back.., but they want to charge me for a diagnosing ( $140.00 ) and I don't have that right now... (VA disabilty, living on it.., sorry)...

I understand they put it in.., it should work..? Right..?

Link to comment
Share on other sites

There are basically 3 major components: Purge solenoid, vent solenoid, and the evap canister. A lot of times if the solenoid is replaced and the light stays on, the canister is full of junk. But since you say you don't drive on dirt, it could be something else. I would just wait and get it diagnosed when you have the money.

Link to comment
Share on other sites

Archived

This topic is now archived and is closed to further replies.



×
×
  • Create New...

Important Information

By using this site, you agree to our Terms of Use.