Jump to content
  • Sign up for FREE! Become a GM-Trucks.com Member Today!

    In 20 seconds you can become part of the worlds largest and oldest community discussing General Motors, Chevrolet and GMC branded pickups, crossovers, and SUVs. From buying research to owner support, join 1.5 MILLION GM Truck Enthusiasts every month who use GM-Trucks.com as a daily part of their ownership experience. 

GrumpyGhost

GrumpyGhost Rusty 1999 GMC Sierra Z71 Ongoing build!

Recommended Posts

Looking good. Keep up the good work.

Share this post


Link to post
Share on other sites

I Know it's been a minute, but I just moved to Florida!

 

Anyhow I had to evacuate to the panhandle of Flordia because of Hurricane Irma. Only been here for 3 weeks and I already got to experience a hurricane. That was about another 700 miles round-trip.

 

I haven't even had a chance to change my oil from the trip down to Florida. Its all good however because mileage wise its right at 5000 miles, so its due, I was just wanting to change it early because it sat all summer.

 

Now for the bad news and next part of the build. I loaned my truck to my sister for one day because her sunroof busted out and I went to a pick a part place and got an entire new sunroof assembly for $200. This is all because insurance wouldn't cover it and the body shop quoted $3000 to fix it. Anyhow i spent most of the day doing that crap -a** of a job and she brings my truck back with a nasty popping sound coming from the rear.

 

She proceeded to tell me it started making a sound about half way to her work which is an hour drive. She said she also went out for lunch with it, and drove it an hour back. Didn't even cross her mind to call me and ask about the weird very loud annoying noise. (Insert crybaby emojis) mehhhh! Why me!!!

 

You know we just got power back in the house like 2 days ago. Still have not had a chance to get to normal life or as normal as can be for being in a new location. Like come on give me a break, we just had a hurricane.

 

I'm pretty sure the rear diff pinion ring is broken. It makes a popping noise about every 6to8 feet moving forward. Last thing I need is for my rear diff to blow up on me when I don't have the tools to fix it myself currently.

 

I was planning on doing a 14 bolt swap in the future but not right meow when I haven't been working because of hurricanes!

 

A lot of crap has been going awry since I have moved down here. Had to replace all my wheel bearings on a tandem axle enclosed trailer with drum hubs. That was a job without having a race punch and other tools. Also it only a temporary fix as I used emery cloth on the axle because it was completely scared and scraped. Gunna have to replace an entire axle, but I slammed a bearing over it with my bfh for a band-aid so I can use it for the time being. I could go on and on with other crap that has been breaking on me. (Incase your wondering, I do not have a trailer brake controller on my truck yet. Future upgrade.) I only pull this trailer occasionally with my truck.

 

So now that my rant is over. I found a guy local who will swap me a rebuilt 10 bolt for my entire diff as a core for $600. Seems like the best deal I'll find in a pinch. Truck is currently parked at my shop. Got my motorcycle in the meantime.

 

I haven't had time to open the cover and look at the diff, maybe its just an axle bearing but I doubt it.(insert lots of crybaby emojis) regardless I don't have an axle bearing puller, not an expensive tool, but just a big paper weight to spend $100 and use it once.

 

Sorry for the Harry Potter book, peace be with yall! #saltlife #comeswithaprice

 

Sent from my XT1254 using Tapatalk

Share this post


Link to post
Share on other sites

Update: sorry didn't take photos!

 

I got some tools from a few new friends and pulled my rear end apart. Kinda sorta.

I dropped the driveshaft, drained the fluid, and took off the cover. Low and behold everything looked exactly the same as when I cleaned up the rear diff a few months ago.

 

I went ahead and took of the wheels and brakes, removed the 8 mm bolt and took out the carrier pin and pulled the axles. Everything looked in tip top shape besides a few scared "spider gears?" Which were that way the last time I had it apart (Correct me if I'm wrong on the name). The fluid was still pretty clean as it was just replaced a few months back and the magnet only had minimal metal "dust". Nothing seemed suspicious. Anyhow all looked well, so I put it back together and left the diff cover off and hooked the driveshaft back up.

 

Started the truck and put in gear while truck was on jack stands. Still heard the popping noise but it wasn't coming from the rear end like I had previously thought.

 

So I buttoned up the rear end with new fluid and took for another test drive. It sounds like a piece of metal is stuck in something and bounces up and down while driving, it only makes noise when driveshaft is moving.

 

So I decided to see if I still had 4 wheel drive thinking perhaps the chain broke on the transfer case or something or anything at this point. Everything is all good there as well. Also there is nothing in the rear brakes or inside the ebrake disc hat or any missing parts. I'm at a loss for what is making this noise.

 

I decided to go for a ride and see if I could "shake loose the noise". Now the popping noise only occurs occasionally or if I hit a bump just right or take off just a bit faster than normal, but it soon goes away.

 

Also the axle bearings looked fine, axles didn't budge when put back on, my pinion nut and driveshaft yoke were tight, for both sides of driveshaft.

 

I'm at a loss here.

 

So now that the noise is intermittent, I'm just gunna drive the truck till either it goes away completely or something break's, I can't pinpoint where the noise is coming from exactly, but my only other guess would be my transmission. I'm saving money to invest in a new one anyhow, but a 4l80e swap is not so easy for me to do with my current situation.

 

I really wanted to do the front end first, maybe even get rid of the crappy rough country lift. It's an okay leveling kit, but really stresses out my suspension. Im thinking of doing a readylift 4 inch lift. Also would like to get some more tools and equipment before I do any transmission or engine work.

 

All this work and I still didn't change my oil! I'm just gunna take it somewhere tomorrow for an oil change, and maybe "talk with the mechanics to see if they have any ideas for the noise" lol

 

As always, sorry for being so long-winded.

 

If any of y'all have any ideas or an inkling as to where is should look next, please do tell, it is annoying to hear the noise going down the road. It is coming from the driveshaft/rear end area. Possibly from the transmission, but the transmission is shifting fine. Transfer case working properly. I repeat, nothing is broken on the rear end from what I can see, unless it has a hairline crack that cannot be seen by eyesight.

 

Sent from my XT1254 using Tapatalk

Share this post


Link to post
Share on other sites

I decided that it has to be my passenger side wheel bearing that is making the noise. I'm guessing a piece of the bearing came off and is now rattling around in the housing. Also explains why it seems the noise moves location. It won't go into my ring and pinion part of the housing because the spider gear is keeping it sealed in the actual axle part of the housing.

 

Did I feel or spot anything wrong with the bearing when I had the axle out, not at all, but I didn't take the time to look down into the housing either.

 

Even if this ends up not being the issue, it is still a good idea for a truck with 190,000 miles.

 

Anyhow, I just ordered a new spider gear set from Yukon axle, new axle bearings, and seals, and new u joints for my driveshaft.

 

All from Amazon for $210.

 

I'm going to rent the tools from O'Reilly's auto parts, I couldn't justify buying all the tools for what will probably be the one time I use most of them. Like $250 worth of tools to do this job.

 

Anyhow, won't have time to do it until next weekend, but I will be sure to take pictures.

 

Yeah I'm still gunna drive the truck, just not gunna put any weight in it. If I have to replace an axle, that's my burden to bear.

 

Sent from my XT1254 using Tapatalk

Share this post


Link to post
Share on other sites

Just waiting on the wheel bearings, haven't driven truck in a couple days. Will try and tackle this project Saturday morning pending a hangover lolcc15335ad012cce3ad890c2b7b6b1a61.jpg

 

Sent from my XT1254 using Tapatalk

Share this post


Link to post
Share on other sites

Well, I had a half day today so I decided to tackle my rear diff today. Took me about 4 hours to do, but only because I had to run and get diff oil. Totally forgot to buy some when I got the tools from O'Reilly's.

 

It really wasn't too bad of a job, just sucks having to lay on my back. Really missing the car lift. Also it was 90°f and the real feel was like 101°f. Brutal!!

 

I didn't get the bearing and seal driver tool set. Instead I used a giant screw pulley puller that was used one time because it only works on Polaris forewheelers. I use it as a punch for a lot of things, its come in handy many times and I keep it in my tool bag always.

 

The new Yukon spider gears fit great and I could definitely tell they had less play than the original spider gears. I could have probably keep my original spider gears, but I don't want to open the diff ever again.

 

I ordered ujoints for the driveshaft but my vise isn't big enough to do the job. I did find that the front ujoint is bad and the cause of my vibration issue. I decided to spin the driveshaft 180° to see if it would change anything, now the ujoint is squeaking badly.

 

Tomorrow I will be going to rent a ball joint c clamp to replace the ujoint.

 

My clanking noise is gone however! The old axle bearings still looked fine to me but as soon as I put the axle shaft into the new ones, I could tell a major difference in shaft play. No pun intended lol.

 

 

Sorry my photos suck, it was hot, my hands were very greasy, and it started to rain and i lost the sun for good lighting.

 

Oh yeah, and check out my new quiet exhaust that I absolutely hate. It's not quite as quiet as a stock exhaust, but I can't really hear it, I'm thinking of ordering a mbrp black exhaust tip to see if it adds any sound, at least make it look better.

 

As always, keep calm, time to party!! 47ef83bd044eabbefc66fb0df0152ea4.jpgdadb902b9866112fe4fde9b3b66221aa.jpg6d3f528fa8f36d940fdd3155cce0cbc9.jpg8389aef1bac1b87d5abaf5b4040b7ca6.jpg7b013cb2a25a792a9592b1b6f9a8eca1.jpg5b1f03b3a0cd6703fbce18f696e90365.jpg1784f14665d134cd0d70ad7094980c79.jpg58f4d9fd096112e37524493e15649e18.jpg9c5049832d634b46c886fa5f2645d1f6.jpg

 

Sent from my XT1254 using Tapatalk

Share this post


Link to post
Share on other sites

More photos, the old spider gears look okay from afar, but if you zoom in, you can scarring which is why I replaced them.

 

I need to invest in a toolbox, one pic is a pile of most of my tools, doesn't look like much, but I jam a bunch of crap into those tool bags. I also have lots of air tools, but Don't have a good compressor to run them yet.

 

I also put in all new seals, again! Lesson here is I should have just invested in new parts when I had the rear diff open the first time. Only cost me like $150 in diff oil when I add all the times I'll filled it up now.

 

I did take photos of the diff being open, but they were all dark so I only included one.

 

I was going to get some high heat spray paint and paint the brake calipers, but I forgot, was also gunna paint the rims, but again, it was hot!!e4289fa4e31de4e71aea4904630fe5d4.jpgf36b48f061490178a7bfc195d0ac835a.jpg2bdd32264c49fbce1ac795b80bc5b88e.jpg82dd64f0f2f35b96610e60e92d6f0629.jpgdabbd085bd9d61beaf85a1031b402c48.jpg54a1c237851c3db3144c49a704885d03.jpgb37bdc48e556e64262ca348d15fa1912.jpg

 

Sent from my XT1254 using Tapatalk

  • Like 1

Share this post


Link to post
Share on other sites

Put a new badge on Grumpy Today! #yukongear&axle

 

First new sticker since I tore all the old ones off when I started the resto.

 

Also worked on getting the 18 year old 3m adhesive from the old side trim off. I finished the passenger side, but still have to finish the driver side. I just used my fingers and gave up because they started hurting. I can see lines and will have to get some goo gone and a quick buff to get a clean finish. Truck needs a wash as well.

 

Still haven't got around to replacing the ujoints, but I also haven't driven the truck for the past few days either.

 

I'm getting antsy to paint the front bumper and rims black to finish the black on green look I'm going for. I'm also looking into getting some black vinyl wrap to put on the roof and top half of the truck. Basically stop the line with the bottom of the windows. My clear coat is starting to peel on the roof and it won't get any better being in the Flordia sun. Will also hide my fresh paint lines much better.

 

So stay tuned for that!

ee643dcf478be2c3faf366666be4fce4.jpg675f81ba13ecf7d1bbf0340a73a55ad2.jpg

 

Sent from my XT1254 using Tapatalk

Share this post


Link to post
Share on other sites

Keep up the good work man!

Share this post


Link to post
Share on other sites

Finally got a chance to work on the ujoints for Ol' Grumpy. She Shure did put up a fight with me this evening. I went and rented a ball joint c clamp/press from O'Reilly's.

No photos cause I was pissed most of the evening. I started with the front ujoint by the transmission figuring it would be the hardest so get it out of the way. The old ujoint came out with a bit of muscling and the new one went in almost seamlessly. Except for one bearing that decided to fall inside of the ujoint and I didn't notice it until I heard it pop while pressing it in. Broke one bearing!

I checked them and put grease on them so they wouldn't do what they did. So as a quick fix I pulled off a cap from the other new ujoint and problem fixed. Then I broke the grease zirt and had to drill it out and replace with the one from the now spare parts new ujoint.

So 2 hours into it now! Did I mention it's hot in Florida yet! Anyhow I ran to O'Reilly's and bought one of their cheap $10 ujoint for the rear. Of course it didn't fit so I decided for now I'll just replace the caps that have to be bolted down And pressed back in the old ujoint. I threw some grease in the caps and called it good for now.

Now for the best part! I was in such a hurry cause I spent my entire evening doing a "quick job" that I forgot to put in the c clips that go inside of the caps. I take it for a test ride and my vibration it is completely gone. Clean up the shop and head for home. I got about halfway home when I hear a big pop and a major vibration.

That's right, the rear ujoint caps popped off!. Its dark now, I left my tools in the shop. So I pull off to the side off the road to see the damage. One cap was gone and the other was still stuck inside which is the only reason I could move the truck to side of the road. To my amazement, it didn't damage anything, driveshaft didn't fall out or anything, just missing the one cap. I happened to have the size 11 wrench to pull off the hold down clamps for the caps and the spare parts new ujoint.

So I pulled the other two caps off of the ujoint that is the wrong size cause and installed the c clips with my crappy emergency wrench on the side of the road. I drove home with no issues and am considering leaving it alone!! I probably won't cause I need my truck for work, but I'm tired of these stupid ujoints!

Fun times living in Paradise!!

Sent from my XT1254 using Tapatalk

Share this post


Link to post
Share on other sites

Oh and as for an update on the vinyl wrap, I've decided to go with carbon fiber and will be doing the roof and about half way down the sides of the truck.

I will be installing it myself and have it ordered but it's back ordered. I didn't buy it on Amazon as I didn't want to risk getting a second hand crap that I read in a lot of reviews. Ordered 3m brand.

I went with carbon fiber look because well, I don't see any other trucks roaming around with it. I see a lot of 2 tone trucks but never black carbon fiber. I may end up doing the hood as well, but not right now.

Sent from my XT1254 using Tapatalk

Share this post


Link to post
Share on other sites

Nothing much has been going on with truck lately, I did get around to replacing the rear ujoint with a Moog brand one. My vibration came back and that when I noticed the half of a fix job I did on the rear joint was the cause.

Anyhow all weird vibrations are gone in the truck. I also changed my oil and rolled over 190,000 miles.

On another note I did notice that one of my spark plugs wires was rubbing against my steering linkage and almost ate through the coating, I have noticed a weird noise occasionally and I'm wondering if the truck was/ is miss firing.

I'll put my scanner on it this weekend and check it, it is probably coming on on needing new plugs and wires, last time I did them the truck had 116,000 miles on it.

Yes I got photos this time!a0d8034d92eb8142235e25628268b23b.jpg7aa76104408d5a080fab7098dbcdf97d.jpg3f3c295582e22d92b25ac60739062343.jpgf51355542e737e8ec95d14431455e014.jpg

Sent from my XT1254 using Tapatalk

Share this post


Link to post
Share on other sites

Painted my rims! Took about 4 hours. Idk if I like them yet, thinking I should have maybe went with matte black. Too late now though!

See photos! Cheers!8850dcde84afbdd7766bf905152f28d9.jpg07beb8bc5d9f6bf3728400465153149d.jpgdbbf3010f5a0a0d20e4b7423546f168a.jpgcf9bfd4f8b833651e2d43283573a7dc1.jpgb23f35c9ad77cc01b61f73c8c7c3d01e.jpg68ee01fcc4bfb4dd372abe1e695ef8f3.jpge566d10e8c9217767ef7204bf7702210.jpg

Sent from my XT1254 using Tapatalk

Share this post


Link to post
Share on other sites

Painted my front bumper and side mirrors!

See photos!e78a355e9195d6ba2787e912bf883a4f.jpg716cf7de10c5fdfb1852192702117603.jpg621b01a68ad7277a7189d626d6ea085b.jpg614d3065f8d85f6e6b6a7ba4dfd8ec49.jpg019341f6fc6e6aa98d0298f3ff1aa65e.jpga664af847da493efe0ea0cf654b77f38.jpg

Sent from my XT1254 using Tapatalk

Share this post


Link to post
Share on other sites

Better shot of what the truck looks like currentlya877286d78fb9c1ac7d020ab32f1abed.jpg

Sent from my XT1254 using Tapatalk

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.




×
×
  • Create New...

Important Information

By using this site, you agree to our Terms of Use.