Jump to content

Recommended Posts

Posted (edited)

A few days ago I decided to clean the throttle body on my 2015 Sierra.  Fast forward to this evening, I opened my hood to replace the air filter and noticed I never reconnected the air intake tube vents.  Any chance I harmed my engine?

 

60_FADB67_82_DA_4_CC4_8571_A7_FD6_A60629

Edited by royalkangaroo

Share this post


Link to post
Share on other sites

It probably rode rough but I doubt you did any damage. You should be fine

 

Sent from my Pixel 2 XL using Tapatalk

 

 

 

 

  • Like 1

Share this post


Link to post
Share on other sites

You’re fine. Only issue would be if you were driving in really dusty conditions like on a dirt road and was sucking dust into the air intake. Other than that I would reconnect it and don’t worry about it.

  • Like 1

Share this post


Link to post
Share on other sites

You're fine... Just never tell the dealer if there is an issue that comes up. They will invalidate every warranty down to your tire road hazard. Lol.

Sent from my XT1585 using Tapatalk

  • Like 1

Share this post


Link to post
Share on other sites

I'm surprised a check engine light didn't come on with that disconnected.

  • Like 2

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now


×

Important Information

By using this site, you agree to our Terms of Use.