Jump to content
  • Sign up for FREE! Become a GM-Trucks.com Member Today!

    In 20 seconds you can become part of the worlds largest and oldest community discussing General Motors, Chevrolet and GMC branded pickups, crossovers, and SUVs. From buying research to owner support, join 1.5 MILLION GM Truck Enthusiasts every month who use GM-Trucks.com as a daily part of their ownership experience. 

Sign in to follow this  
BShurilla09

2015 Suburban Heated Steering Wheel Swap

Recommended Posts

Has anyone else done this upgrade on their 'burb? I already had radio controls, just upgraded to a steering wheel that also had heat. Heat works, but now I no longer have any lights on the steering wheel, can't control the DIC, and I am getting a LIN Bus communication error. I checked and I do have the correct LIN wire in pin #2 on the clockspring, and pin 20 on the cluster connector, and I have good continuity between the cluster pin, and the connector in the steering wheel. Only thing I can think of is the steering wheel I got has a bad LIN module? I could try pulling the heated steering wheel off, and put the old, non heated wheel on the new clockspring, but other than that does anyone have any thoughts? The only other thing I could think of is trying to grab the LIN module from the non heated wheel and try swapping that into the heated wheel, but I assumed that would loose control of the heat, not sure on that one.

Share this post


Link to post
Share on other sites

That does seem odd.  To be sure I understand, you swapped the clockspring as well and have continuity on the LIN Bus wire all the way through?  Was the correct heat connector already present in your dash harness?

 

I'd swap back in the original wheel (and keep the new clockspring) to isolate where the issue may be.

Share this post


Link to post
Share on other sites

Yep, that is correct, I have the new, correct clock spring with continuity all the way through, the heated wire was already there, and heat even works. 

 

Tonight I swapped the right hand controls over to the old control pad and everything lit up, and the heated wheel still works.

 

I am not sure if it was a bad module on the used wheel, or of it was just an incompatibility issue. The donor wheel came from a Denali, but the part number shows it was compatible, so I am guessing a bad module.

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Sign in to follow this  



×
×
  • Create New...

Important Information

By using this site, you agree to our Terms of Use.