Jump to content
Sign in to follow this  
linda

NAV and 6 disk changer in a Silverado

Recommended Posts

everything has been sent to you "2003blackz71". I would be more than happy to post my schematics and wiring diagrams if someone has a page they wanna host the pics from. I just have them saved on my drive, this forum is setup to only except hosted pictures, not direct links.

 

Linda, Poonis and all the rest of you are awesome in your knowledge!

I have read all 61 pages of this post, but man it is hard to keep track of all the details to figure out which Nav unit will fit my truck correctly as plug-n-play.

I have a 2003 GMC Envoy SLT XL with Bose, but without Y91 as the code and no 6-disc changer.

 

1) Will the Non-touch screen HU part number "15108421" (04' GMT800 Non-LUX) fit into my vehicle as plug-n-play assuming I buy and install the GPS antenna? (This unit came out of a 2004 Hummer H2)

 

2) What other units will fit in my truck as plug-n-play, assuming I buy and install the GPS antenna?

 

 

3) Do you suggest the touch screen over the non-touch screen?

 

****Please keep in mind that I just want a quick install of a stock navigation unit to use, I'm not looking for real high tech options or anything special.

 

I want to thanks all of you for your help!!!!!

 

 

 

Hey E50,

I did the conversion on my '03 Tahoe from a 6 disk changer AM/FM in-dash to a Touch Nav non-lux (no Y91-92) that came with the antenna and disk I bought on Ebay and it's plug and play. Just find yourself a non-lux Touch or non-Touch Nav sys and the remote 6 disk changer in Ebay and your set. :lol:

Share this post


Link to post
Share on other sites
the BOSE system is a MUST! you have to have BOSE audio system from the get go. If not...you will spend WAY to much for the retrofit.

 

This "grocery" list will either turn you off, or get you started. To me the price is worth keeping the factory look. Keep in mind these prices are very flexible depending on where you find the parts.....Salvage yard, Ebay, dealer,....etc.

 

Um8 NAV Head Unit----- #15204335,15204334--------------$1300

Nav Disk----------------- #15105609--------------------------$150

GPS ant------------------ #15207447,15135178--------------$75

Mic------------------------#25705367--------------------------$45

Amp--------------------- #15199992,15199884,15112662---$400

AUX harness------------#15312903---------------------------$25

AUX CD changer-------#15055250---------------------------$180

 

there are some very minor wiring changes that need to be made at the AMP harness but they only took me about 20 minutes to do, and it doesnt require any cutting, so if you want to return to your original setup, its not a problem.

Share this post


Link to post
Share on other sites

I didn't want to crash this thread, but Linda's inbox is full Well, here goes.

 

 

Linda, can you help? I have a cobalt 2006 and there are two harnesses in the back. One is 12 pin auxulliary (I suppose/hope.) Any chance you know the readout of these aux pins? I have been all over forums (mostly in the turbo racing ones) but no one seems to have radio electronics knowledge like you. I am in awe.

Share this post


Link to post
Share on other sites

I have a Yukon denali 06 I'm looking for the cd changer, any ideas where I can find one??

 

Any help would be great

 

Thank you

Share this post


Link to post
Share on other sites

I have a 2008 Chevy Suburban and just installed a delphi touch screen nav. I have installed the gps and also had the dealer program it for my vin. I am having a problem with it not playing very loudly and when I took it to the dealer they said i needed an amp for it to work properly. I was wondering if anyone had any suggestions. Thanks

Share this post


Link to post
Share on other sites
I just bought what was supposed to be a lux navigation HU. After completing the installation according to the great instructions found here, I hear door chimes but no sound comes out of the radio. I read a post about a guy with a Denali who had the same problem...rear headphone jacks work but no sound from speakers. The funny thing is that when I press VOL+ and VOL- there is no indication on the screen that I'm even doing anything. Does this seem indicative of a non-lux HU or some other problem? I don't think the amp is bad because the chimes work. Any help would be appreciated. Oh, by the way my HU does not have "Spacious" and "Driver" like so many of you have mentioned. I just have "EQ1" "EQ2" "EQ3" "EQ4" and "Custom."

 

 

 

did you ever figure this out. I have a 03 h2 and put a 06 factory nav system (05 gmt800 tnr) in it and had the dealer program the antitheft lock out out and everything works except there is no sound I get the door chime out of the left front door speaker but cd or radio sound. I have read though several sights and can't find what the fix is.

Share this post


Link to post
Share on other sites
Just wanted to post a pic of my finished install. Everything works good, just need to get to the dealer next week to program my AMP for my surroundings. The AMP came out of a Hummer, so i need them to program it like a sierra denali to make it sound better. Right off the bat this AMP sounds TONS better than the stock silverado AMPs, much more adjustments and sound clearity. Cant wait till its tweeked. There were some small wiring MODs that were needed at the AMP and a little trimming to do to get the 6 disk changer in the console, but it looks sharp, and best of all...it looks like it came from the factory like this. I have to thank SPERRY and Pbuilder for helping me out with the DOCs i needed to make the wiring changes!

done.JPG

 

Hi Linda

 

Very good job. I have the same Navigation system on my Toyota Matrix 2003 and have been encountering some problems as below, could you help me getting the equipment to work normally again? Below is what is happening:

 

My Matrix's Delco DVD Navigation system's Hard buttons are malfunctioning at times. The Power button, Music CD, Navigation "Destination", Setup and DVD "Eject" buttons do not respond at times in any mode even after pressing them several times for e.g

 

(1) I will not be able to select the particular FM radio channel assigned to the hard button even when its in FM mode.

(2) The DVD will not eject or the Destination menu screen will not appear.

(3) The Power button does not respond, it will not power "OFF"

 

Only the radio is working properly with some buttons to select pre-assigned stations.

I pulled the unit out opened it up to see if any wirings were loose, tightened all wiring connections and assembled it back again. The screen does not display anything even the clock display is gone, just a black lit up screen with radio stations playing in the background.

It used to function perfectly for over 5 years since I bought the car, its malfunctioning since a year. Any help to reset it to normality would be appreciated?

Share this post


Link to post
Share on other sites

I have a 2003 Silverado that I would like to install a navigation radio in. Presently non lux bose. I have assembled all of the equipment including a lux bose amp and a lux nav head. I read about the wiring changes that have to be made. Does anybody have the wiring diagram of the changes?

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Sign in to follow this  

×
×
  • Create New...

Important Information

By using this site, you agree to our Terms of Use.