Jump to content
  • 0

Dash emits a repeated tic-toc sound


oquevix

Question

Alright now. Yet another problem with this 2003 Yukon, 5.3L Z71, 55,000miles. A tic-toc sound - very methodical like a loud clock comes from the driver's side dashboard. It comes on after a few miles of driving ans stays on until the engine is turned off. It even stays on when the vehicle is at a stop light. Kinda like my own little drummer along for the ride.

 

Any ideas on what it is, what causes it and what the fix is.

 

Thanks,

 

Axe

Link to comment
Share on other sites

0 answers to this question

Recommended Posts

It's one of the A/C door actuators. While it's making the noise, try moving the temp lever (or knob) to a different position and see if it momentarily stops as the temp is changed. Or, it may go away for a while.

 

If that does nothing, try chaning the mode (upper vents, lower, bi-level, etc.) to see if that affects it.

 

We mostly see the left temp actuator and/or the mode actuator cause this problem. Hopefully, it's no the right temp actuator as that requires several hours labor to replace.

Link to comment
Share on other sites

Archived

This topic is now archived and is closed to further replies.

  • Recently Browsing   0 members

    • No registered users viewing this page.
  • Forum Statistics

    246.2k
    Total Topics
    2.6m
    Total Posts
  • Member Statistics

    333,913
    Total Members
    8,960
    Most Online
    Al L
    Newest Member
    Al L
    Joined
  • Who's Online   4 Members, 0 Anonymous, 609 Guests (See full list)



×
×
  • Create New...

Important Information

By using this site, you agree to our Terms of Use.