Jump to content

shift into 2nd.. weird shift


Recommended Posts

I have had this issue for quite some time. Dealer replaced a presser regulator or sensor in the tranny, with no change.

 

When shifting under moderate to little acceleration I get this werid shift from 2st to Second.

 

for lack of better discription it feels like the truck shifts twice. It shifts slighty and then a moment later firmly shifts, tow haul or not it does it.

 

2003 Tahoe LS 4x4 50k 9done it sice 30k 5.3

 

 

any ideas?

Link to comment
Share on other sites

I have the same problem with my truck!!! mine is just with the 2nd to 3rd shift but it feels like it trys to shift then does it again. Hope someone knows what this is, hopefully an easy fix and not a rebuild!!

 

I have had this issue for quite some time.  Dealer replaced a presser regulator or sensor in the tranny, with no change.

 

When shifting under moderate to little acceleration I get this werid shift from 2st to Second.

 

for lack of better discription it feels like the truck shifts twice.  It shifts slighty and then a moment later firmly shifts, tow haul or not it does it.

 

2003 Tahoe LS 4x4 50k 9done it sice 30k 5.3

 

 

any ideas?

 

 

 

Link to comment
Share on other sites

Mine too from 1 to 2. Dealer replaced my pressure control solenoid too, and it went away for a little while. I notice it more when my tranny has heated up, like after a trip on the freeway, or alot of stop and go traffic. It is much worse when turning from a stop sign or stop light and going slow. I have never noticed it under 210, on the water temp.

 

It is annoying isn't it. I thought I was going crazy, and was the only one with that problem. Glad to see I am not alone. Mine is an 03 Silverado Z

Link to comment
Share on other sites

Yep, if I floor it, shift smooth as silk, only under moderate acceleration. i notiuce it the same all the time no matter what the temp is. If I apply more gas right in the 'lag' time, i can seem to 'mask' the shift. I didnt realize how used to it I was until I drove my mothers Suburban and I found myself antisipating that "2nd shift"

 

I ONLY notice it from 1st to 2nd.

 

Good to see Im not alone.

Link to comment
Share on other sites

Hmm mine does it too, intermittently, but does not do it in Tow/Haul mode. I did not think much about it at first. It only seems to do it under light acceleration. Based on this thread it appears to be common to '03 models like mine. I was going to have mine looked at during the tranny service since it is under warranty.

 

I dumped my '02 due to piston slap a couple of years ago and went with another brand for a while. I really like the comfort of the Chevy so I gave them a second chance. I hope the transmission is not the "weak link" of the '03 models.

Link to comment
Share on other sites

There is a TSB out for something similar where the PCM needs to be reflashed to change the timing of release and engagement between the different clutch packs and gears.

 

Perhaps if you post in the GM tech area he can point you towards the TSB

Link to comment
Share on other sites

  • 5 months later...

My 2002 Avalanche does the exact same thing. Does anyone know the part # on the transmission pressure control solenoid valve? Is it the same as the 2003?

 

Where can I find instructions to replace this part on my AV? (I don't like other people working on my cars) Are there instructions in the Chilton guide for this truck?

 

Thanks!!

Link to comment
Share on other sites

Archived

This topic is now archived and is closed to further replies.

  • Recently Browsing   0 members

    • No registered users viewing this page.
  • Forum Statistics

    246.3k
    Total Topics
    2.6m
    Total Posts
  • Member Statistics

    333,994
    Total Members
    8,960
    Most Online
    vcastilloaz
    Newest Member
    vcastilloaz
    Joined
  • Who's Online   3 Members, 0 Anonymous, 834 Guests (See full list)



×
×
  • Create New...

Important Information

By using this site, you agree to our Terms of Use.