Jump to content

Issues with 1997 Z71


Recommended Posts

Just bought a rust free Z71 with a clean interior. It just has a few things that need work.

 

One thing being the wipers. They come on with the switch, but they seem to have a mind of there own. Will sometimes not stop when turned off and will stop wherever they decide to on the windshield. Is this issue in the turn signal switch itself or the wiper motor?

 

Another issue I am having is I can't get the air to blow out of the dash vents. It does seem to work switching it from floor and defrost just not the top ones. Is this issue in the dash controls or is this a mode actuator not moving the flap all the way?

 

 

Just trying to narrow down these issues instead of guessing.

 

Thanks for all the help!

Link to comment
Share on other sites

Just bought a rust free Z71 with a clean interior. It just has a few things that need work.

 

One thing being the wipers. They come on with the switch, but they seem to have a mind of there own. Will sometimes not stop when turned off and will stop wherever they decide to on the windshield. Is this issue in the turn signal switch itself or the wiper motor?

 

Another issue I am having is I can't get the air to blow out of the dash vents. It does seem to work switching it from floor and defrost just not the top ones. Is this issue in the dash controls or is this a mode actuator not moving the flap all the way?

 

 

Just trying to narrow down these issues instead of guessing.

 

Thanks for all the help!

 

Link to comment
Share on other sites

Wipers issue prob going to be in the motor. Don't know if yours will come apart. But I have taken them apart and cleaned brush that rides on copper strips to solve that. On dash vents. Drivers side of heat cool box in end middle ways You can feel the rod. Move it and air will come out of vents. Not sure what needs to be replaced. Don't think it's vacuum like old school

But maybe somebody jump in and help you

Link to comment
Share on other sites

My 97' GMC K1500 wiper circuit board was replaced under a recall. Nothing wrong with the motor. Circuit board is located in same housing as the motor.

 

Under the dash below the radio, there is linkage that can get gummed up over the years. This linkage controls a diverter gate to transition air flow from you HVAC system. It is electrically operated.

Link to comment
Share on other sites

  • 2 months later...

on the HVAC issue, they are not vacumn controlled, I have a very similair problem. the actuator motor on the drivers side of the box controls the flap which directs your air. After getting under there I discovered one of the rods had come loose and now I cant get it to go back on. I would suspect you have the same issue. There are actually two rods connected to that motor, my upper one has come off, I have a z71 extended cab as my weekender and a 97 Tahoe for parts. Now I'm trying to figure out how to get the boxes off and switch it out.

Link to comment
Share on other sites

  • 1 month later...

The vent issue sounds like a blend door issue. I can't say for sure but I think they are vacuum operated. You'd have to get a vacuum schematic to find out which lines to test at

 

 

my uncle had the same problem with the door. i wanted to ask you if its not vacuum operated then? and how to get the vacuum schematic for finding out.

Link to comment
Share on other sites

Archived

This topic is now archived and is closed to further replies.



×
×
  • Create New...

Important Information

By using this site, you agree to our Terms of Use.